Wifi problem on boot (RTL8188cus)

I downloaded the pimusicbox image yesterday and put it on my 4gb micro sd card…
When I try to boot only with ethernet cable everything is fine. But when i have my wifi stick plugged in it doesn’t boot anymore. Following error comes up:

FATAL: Module p80211 not found.
Failed to load p80211.ko.
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
Error for wireless request “Set Power Management” (8B2C) :
SET failed on device wlan0 ; Operation not permitted.
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

I already found out that I am not the only one having a problem with this chipset (RTL8188cus) but I dont know how to solve this?
Can you tell me how to correctly install the drivers for this chipset on pimusicbox?
I tried out a solution for raspbian but then it comes up an error that im on another system… (musicbox)
I hope you can help me.

Dear Collegaues!

Found, that PiMusicBox is the best music player.
I installed on last week on my RPI2 with DAC+. Its running well, but I cant install
my TO-Link WN 725 / RTL8188eu . I search for a week on internet, but none of
sample work on my RPI.
Two question:
Is there any supported Wifi dongle, You can suggest to use, out-of the box?
So I plug in, reboot, and nothing else, to do with?

Or can sy. suggest a good step list, I must to do to config well my small WiFi dongle?
I tested 5 method, but all fails /im not a software engineer :frowning: /


I wrote some instructions a while back that worked just fine for me…Have a look, see if it helps :slight_smile:


EDIT: Strange, clicking the link brings up an error. If you go to phreemms.com/RPi and then click on the pdf, it should open ok.

Thanks! Neil, ill try