Edimax Wi-Fi woes

As stated in a github discussion, I’m having trouble getting my Edimax EW-7811Un to work on Pi Musicbox release 0.5. This is the error:

root@MusicBox:~# ifup wlan0
FATAL: Module p80211 not found.
Failed to load p80211.ko.
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not permitted.
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

The device works just fine with a stock Raspbian boot, so I don’t know where the problem is–or why the p80211 module is even trying to be loaded, since it is not the module for this device. That would be rtl8192cu and it is already loaded.
I installed rpi-update and upgraded the kernel, but it didn’t make any difference.


It’s a RTL8188CUS chipset. You could try this:

I have not tried that because as I mentioned, the wi-fi works just fine when I boot into regular Raspbian Wheezy. What’s extra-frustrating is that just yesterday I re-imaged the SD card and booted into Musicbox and left it be since I was running out the door for a bike ride. When I came back to it this morning, I saw that the wi-fi was working. “Great!” I thought and proceeded to log in via the web interface where I tested out the pre-loaded sources. Worked fine. I configured Gmusic and waited while it rebooted. When it came back up, the wi-fi was gone again. I have no clue unless whatever process rewrites the configs when you change the web interface is throwing in a monkey wrench. I’m away from it again now but if it isn’t magically up again when I return, I will re-image the SD card yet again and see if I have luck on first-boot. If so, I will save copies of the network scripts and any Mopidy/Musicbox configs I can find and see what the differences are after I tweak it for Gmusic.

*edit: fixed it, missing a letter in my SSID. omg.

I have this problem with my Raspberry Pi 2. Everything works perfectly when the Pi is running through the Ethernet cable but not the Wi Fi. I am trying to connect to a Netgear Nighthawk router. I am using an Edimax 7811UN wireless adapter with MusicBox 6.0. I followed all threads including updated rasping, modified interfaces file in /etc/network/, nothing seems to work wither automatically or with a static IP set.