Pi Music Box RC2 - Wireless problem

I tried RC2 today and i see the wifi network connectivity problem after reboot. Wired network seems to work. I downgraded to RC1 and did not see this problem. Is there anything i need to do with RC2 for Networking.

1 Like

Same here… with the final 0.51 version.
After rebooting the system sometimes hangs in the “waiting for network” loop.
Futher above in the boot log there is an error about a 80211.ko file not being found.
In that case the wifi stick does not flash its LED at all.

After some further reboots it works again… (despite still showing the ko-file error message)… very strange.

Same bug here. Tried both static and manual in /etc/network/interfaces for wlan0 but the issue persists. My dongle is the Edimax 7811, which seems to work great in Raspbian.

I’m having the same problem … New installation of PiMusicBox 0.5.1 works fine but after first reboot, sometimes after the second one my Wifi is not coming up.
The problem ist I’m having a RaspberryPi A only with a Edimax Wifi Dongle (This one worked quite well with Raspbian and older PiMusicBox Versions).

So after rebooting I can’t use the system anymore … first I thought of having a corrupt SD card or something but I figured out only Wifi is not coming up and System is in “Waiting for network” loop.

Hi, same issue over here. Scratching my head and was about to buy a new WiFi single as I thought it was unsupported… But now I’m not sure

@surfacescan I’m waiting for a ModMyPi WiFi n dongle in substitution of my Edimax. I’ll let you know if this improves something.

I currently use a B+ model with the Edimax dongle. Do you have the Edimax as well? Which model of Raspi do you have?

Same here - Tenda W311U+ dongle. Works flawlessly in Raspbian, no luck with MusicBox after reboot.

I still see the same problem on 0.5.1 version. I downgraded to 0.5.0 and it works. I tested this on Model B and B+. Even i have Edimax which works absolutely fine on 0.5.0.

Also facing the same issue with Wi-Fi. Is there a place I can download older releases?

@siawyoung, you can try this workaround for the Wi-Fi on first boot issue:

Or you can obtain the 0.5.0 release @ pimusicbox.com/musicbox0.5.zip
Keep in mind, many of the more exciting features such as Spotify playback are not as stable in older versions.

[reposted from github]

Hi @toolboc, I can verify that your workaround works. Tried rebooting several times - still works. Will stick with this till a fix addresses this issue.


with 0.5.2 the wifi network seems to be fixed but after boot i can not open the web page and not use mpd. I can ssh. has any one seen this issue ?

When logged in via ssh try and see if the Mopidy process is running.

Hey @red - it seems this problem has been fixed with the latest update. I’m not exactly sure what dongle I have - its a very much made in chine no name brand. I will try to get it working under the new changes and keep you posted…

Thanks for the pointer @kingosticks. I saw mopidy services was failing to run. I have a USB soundcard (http://www.amazon.co.uk/dp/B002FI7GWK/ref=pe_385721_51767431_TE_dp_1). I had enabled “Hardware Mixer - For some USB audiocards (DACs), you can enable hardware mixing of the volume.” This had worked earlier (0.5.0) but with latest 0.5.2 it seems to be a problem. Disabling Hardware Mixer is working.

Mopidy service start Error with Hardware Mixer enabled on 0.5.2

2014-12-23 12:26:18,852 - INFO Starting Mopidy 0.19.4
2014-12-23 12:26:20,833 - INFO Loading config from: builtin defaults, /etc/mopidy/extensions.d/spotify.conf, /etc/mopidy/mopidy.conf, command line options
2014-12-23 12:26:22,369 - INFO Enabled extensions: spotify, mpd, http, stream, spotify_tunigo, podcast-gpodder, local-sqlite, youtube, podcast-itunes, http-kuechenradio, simple-webclient, softwaremixer, local-whoosh, dirble, moped, musicbox_webclient, websettings, podcast, local, tunein
2014-12-23 12:26:22,372 - INFO Disabled extensions: alsamixer, gmusic, scrobbler, subsonic, somafm, internetarchive, audioaddict, soundcloud
2014-12-23 12:26:22,375 - WARNING Found alsamixer configuration errors, the extension has been automatically disabled:
2014-12-23 12:26:22,378 - WARNING alsamixer/control must be set.
2014-12-23 12:26:22,381 - WARNING alsamixer/card must be set.
2014-12-23 12:26:22,383 - WARNING Please fix the extension configuration errors or disable the extensions to silence these messages.
2014-12-23 12:26:39,737 - ERROR Did not find unique mixer “autoaudiomixer”. Alternatives are: software