Wi-fi on first boot only

Hi Everyone,

I just got Pi Musicbox and after trying to make mopidy + raspbian work this seems like a sure winner. I’m trying to get google music to work which, from discussion, seems to indicate I should use 0.5b2 over 0.5 but I’m not there yet.

I am trying to make this work with Wifi on the pi for the first time (happen to have a USB wifi stick hanging around). When I build the image, I edit the config for SSID and PSK and hook it into the PI

It works absolutely perfectly on that initial startup, but as soon as I restart (after changing settings etc.) I lose the connectivity. I think it might come on briefly (using the router to check) but it’s hard to confirm. I tried plugging in my TV over HDMI to monitor but the detection of HDMI seems to alter the boot process (I got the impression it does a less automated boot but might be wrong).

Any thoughts about where I can even begin on this would be appreciated? I knew where to find logs for mopidy but I’ve got no idea where I’d begin in tracking this down.


First off, you’d be best with using the very latest version and updating the rpi firmware if not done so already.

I think I had the same problem some time ago and suspected SD card corruption was occurring during the reboot. I ended up swapping the SD card and the power supply but I can’t remember which was the issue. If you’ve got spares of both lying around its maybe worth a try.

Hi kingofsticks, thanks for the help!

I was trying the beta in the hope I’d tease out a difference. I’ve now tried 0.5 and 0.5b in multiple wipes on 2 SD cards. I can try a power supply but find it interesting that it’d be the issue after working for the WIFI card every first time (and constantly on raspbian between reboots - I tested that last night)

As for firmware updates do you mean this? https://github.com/Hexxeh/rpi-update

I’ll give that and the new power supply a try.

Ok. I did an update and upgrade, tried new SD cards and power supplies without success. I’ll stick with Ethernet St the moment. Music is now working through gmusic. I was getting ‘forbidden’ when I was putting in my device I’d but when I leave it blank it works perfectly. I might try to use bluetooth to route connection but for now it’s functional and I’m tempted to leave it :wink: thanks for the help.

Sorry, it’s so annoying I can’t remember exactly what I did.

If you leave the device ID blank, the extension will actually try and look
it up from your gmusic profile. It’s rather clever.

I’m also facing this problem. It works perfectly fine the first time, but after a reboot, it can’t connect to wifi anymore. I’m on the latest firmware 3.12.34+. The power supply and my wifi dongle (AE1000) should work fine because with the exact same hardware I can run Raspbian just fine.

Any clues?

Can confirm, I am also facing the same problem using latest release.

Anybody find a solution to this? It’s pretty frustrating/


1 Like

It’s fixed in the 0.5.2beta image ( http://pimusicbox.com/musicbox0.5.2beta.zip ). Fixes some other bugs too

1 Like