Connection to MusicBox not possible

Hey guys,
tried several different things to get my Netgear N150 (rtl8188cus chip) working with musicbox. No possibility to attach ethernet cables here, so running the install script and stuff not possible. After some attempts I found the step by step install from scratch, witch I ran through.

Wifi is working now, but I am not able to connect to the pi through the browser (tried different devices). I can’t find any troubleshooting pages, guess there are none? Don’t know where to start looking for errors.

Any suggestions would be appreciated!

if the original problem was that you could not insert the wifi credentials and do not have ethernet option, then you could have simply edited the settings.ini file and put in the credentials. that is, edit with another computer or maybe with a usb keyboard and a display. then you would have had wifi on initial boot.

how do you know that wifi is working now? are you able to connect with a mpd client? or ssh or something else? if that is the case, perhaps your webclient extension is not installed correctly?

He knows wifi is working because he just ran through the create musicbox script.

Can you provide the output of sudo -H -u mopidy bash -c '/usr/local/bin/mopidy --config /etc/mopidy/mopidy.conf config'.

I see that I misread your post. However, you still can download wifi firmware and manually install it, if you decide that that is easier.

It’s a good point, if you can identify the specific missing firmware we can
add it to the base musicbox install.


Traceback (most recent call last):
File “/usr/local/bin/mopidy”, line 5, in
from pkg_resources import load_entry_point
File “build/bdist.linux-armv61/egg/pkg_resources/”, line 3020, in
File “build/bdist.linux-armv61/egg/pkg_resources/”, line 614, in _build_master
File “build/bdist.linux-armv61/egg/pkg_resources/”, line 920, in require
File “build/bdist.linux-armv61/egg/pkg_resources/”, line 807, in resolve
pkg_resources.DistributionNotFound: tornado>=2.3

I also tried another thing (again), I took the complete image and wrote it to another SD Card to see if I’m now able to install missing drivers. It looks like the driver is working (the kernel is the same btw), I can run commands like
iwlist wlan0 scan
and others but when I try to connect to my wifi it doesn’t accept an dhcp offer. Something must be configured somehow, question is what! :smile:

Ok. Took the 0.5.3 version now, clean install. Didn’t touch any files in the linux system, just used the config ini with wifi settings and now its working.
Seems like musicbox doesn’t like any changes in the file system not done by the ini-file.
Thanks anyway!