What address do I put in for my network drive?


#1

Hi,

I’m connecting my Pi via LAN to my Archer C7 router. I’ve an external hard drive that’s shared via the router but I can’t get the Pi to see the drive. I think this is because I am not putting in the correct address. Could someone confirm what this should be?

My router address is: 192.168.120.10. According to the router the Pi is connected via LAN
The network/media server name is ‘Esper-Share’
The router tells me the network neighbourhood link is \Esper-Share
Folder name is ‘Music’
Folder path is G:/Music
It’s password protected, which I have included in the Musicbox set-up.

Under the Network Drive settings in Musicbox I have tried to type in all manner of permutations from the above details (backslashes, forward slashes, smb, IP address etc etc) but nothing is happening after rebooting.

What address should I be typing in here? Do I need to mount the drive first? What checks can I do (I’m using SSH via Putty) to see if the drive is even visible to the Pi?

Thanks in advance.


#2

Sorry for the late reply.

You don’t need to mount the drive first. I think in your case here you’d want to enter //192.168.120.10/music but the share name (music) doesn’t have to be the same as the directory name so it’s possibly something else, hopefully that’s enough to get going on. However, you might also fall victim to the cifs version bug. The workaround to that can be found at Smb connection error 112 host is down