Having trouble setting up my network drive

Just setting up my first pi musicbox. After a bit of fettling I have internet radio and streaming. I can’t seem to connect to the NAS. Its a wd mybooklive connected via a tp link router. I’ve tried a few different address formats such as // and //wdmybooklive/public/sharedmusic with and without a user and log-in. I can connect to the folder via web browser and Windows pc so the drive is generally connected just not in the musicbox. I’ve enabled sharing on the musicbox (I think) and it is enabled on the wd, it streams to my tablet.

I’ve had a look through the archives and tried a few things without success. Not really sure what to try. What extra info might help troubleshoot?

Minor update. I’ve just tried a different disk image (Volumio) and the NAS connected straight away and played music over the network just fine. I’d still like to get Musicbox working as the Internet radio seems better so if anybody has any ideas I’d be interested.

Do you know if your drive is FAT32 or NTFS format? The latter is not currently supported by our startup script but it’s not difficult to fix. Otherwise, do you see any errors during startup at the stage where it prints “Mounting Windows Network drive…”? You can also debug what is going wrong by attempting to mount the drive manually:

  • Enable SSH and login to musicbox
  • Run one of the following depending on your share security:
mount -t cifs -o sec=ntlm,ro,guest //wdmybooklive/public/sharedmusic /music/Network/
mount -t cifs -o sec=ntlm,ro,user=share_username,password=share_password //wdmybooklive/public/sharedmusic /music/Network/

If you require the 2nd version, with a username and password, then be careful if you have any special characters that will ignored/interpreted differently by the terminal such as *, $, etc.

Thanks. I think it is formatted Ext3, not sure how to check with a NAS but that is the default according to google and I haven’t changed it.

Tried mounting it and
mount -t cifs -o sec=ntlm,ro,user=share_username,password=share_password //wdmybooklive/public/sharedmusic /music/Network/
didn’t work but this did:
mount -t cifs -o sec=ntlm,ro,user=share_username,password=share_password // /music/Network/
I could navigate to it inside Putty via SSH. Couldn’t see it from the web browser interface, though.

… OK Just copied those login settings and after a reboot it is now connected to the NAS and playing music. Only difference from yesterday is that I’m on a wired connection. I’ll try it on the wifi dongle, once I get it back