Access drive from LibreELEC

Hey guys,
I just setup my Pi MusicBox and i love it so far. Everything working exelent except this one thing:
I have another raspi with LibreELEC/Kodi and my films and music drive plugged to it. Now I’m trying to access that drive from my MusicBox and I don’t have any luck. The drive is called “1TB Baby” and I can reach it from my Windows machine and my Linux Mint laptop. MusicBox settings so far are:

vers=2.0 because my LibreELEC uses Samba 2 and 3
Login data is 100% correct

I tried various different way of writing it:
//192.168.x.xx/1TB Baby
//libreelec.local/1TB Baby

Still: Network - Not tracks found.

Any help?

Please provide the error message in the startup log.

Is that the share name?

Having a space will definitely not work, and URL encoding won’t work here. But you should be able to replace the space with it’s escape character (\040). So

mount_address = //192.168.x.xx/1TB\040Baby

Or maybe enclosing it in quotes will suffice?

mount_address = "//192.168.x.xx/1TB Baby"

Thanks for you help!

Startup log says:
Mounting Windows Network drive: //\040Baby
mounting error(95): Operation not supported

Enclosing it in quotes erases the mount address after reboot.

I did not expect that.

Anyway, sounds like mount_address = //192.168.x.xx/1TB\040Baby worked and now we have a different problem. The Samba error messages are so unhelpful, the following can all mean the protocol version is wrong:

mount error(13): Permission denied
mount error(95): Operation not supported
mount error(121): Remote I/O error

So maybe try a different version? e.g. mount_options = vers=3.0 and if that doesn’t work, even 1.0 is worth a go.

It’s working now! Here’s what I did:

First I changed Samba to vers=3.0 (with LibreELEC set to accept minimum v2, maximum v3). Then I had to point MusicBox not to the drive itself, but to my musicfolder on the drive. Spaces and capital letters are important:

//XXX.XXX.X.XX/Drive Name/Musicfolder

Scanning the whole drive crashed MusicBox:

(mopidy:2838): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY

Whatever that means?! The log mentioned something about some files from Windows recycle bin folders but I’m not sure that caused that.

Scanning roughly 8000 files took me about 1 1/2 hours. You’re welcome. :hugs:

It’s a warning, you can ignore it, as you found out.

I tried to make this clearer earlier but the term “drive name” doesn’t make sense in context of shares. It’s the share name that matters.

I’m not sure why this is. I would guess because there are some other files in that share that our scanner really does not like; in which case I would have expected some errors in the scanner log. And even so, I thought that samba ignored directories under the actual share. It would be interesting to know the output of the mount command on your system.

root@MusicBox:~# mount
/dev/root on / type ext4 (rw,noatime,block_validity,delalloc,barrier,user_xattr,acl)
devtmpfs on /dev type devtmpfs (rw,relatime,size=495480k,nr_inodes=123870,mode=755)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=100020k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=200020k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda1 on /music/USB type vfat (ro,nodev,noexec,noatime,nodiratime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
/dev/mmcblk0p1 on /boot type vfat (rw,nosuid,nodev,noexec,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
// Baby/Musik on /music/Network type cifs (ro,relatime,vers=3.0,cache=strict,username=root,domain=,uid=0,noforceuid,gid=0,noforcegid,addr=,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1)
1 Like

Interesting, thanks!

I think the biggest improvement we could make here would be to automatically try the different protocol versions (from highest to lowest) to find what’s needed. Oh, and to document how to handle spaces in names.

1 Like