Trying to Reach musicbox

I was using pi musicbox 0.5. It work absolutly perfekt, but suddenly it stopped working.
It’s stuck at “trying to reach musicbox”.

Things I tried;

  • different raspi
  • different SD-Card
  • raspi-update
  • LAN or WLAN
  • musicbox 0.4.3
  • disable spotify etc…

…now I ran out of ideas, maybe someone has an idea what i’m doing wrong.


I have the same thing with 0.5
Only I installed it on a sd card, then I started it with default settings.
After changing settings in the webbrowser en restarted then it stopped.
The CLI tells me that its loading config from builtin defaults. Then it takes a long time and then it says

**(mopidy:2546) Critical **: nal_reader_get_ue: assertion 'i <=32’failed

I have a raspberry pi + a wolfson audio card

1 Like

I did a clean install 0.5 and rebooted, everything is ok
Then I added a samba share only, then it crashed.

Then I did a clean install and only added spotify, then it run OK.
Then I tried to browse spotify and connection seems lost to the browser function.
I can still ping the device. Dont know what to do.

I have this problem when trying to use it with my Google Music. Looking through one of the gmusic logs (can’t remember where) while it’s loading, it seems to get stuck after pulling track/album or whatever info, and then loops through trying to pull the same info… from what I can gather anyway. I have All Access as well.
Turning off gmusic support, and using just a soundcloud account works fine then.

I think I fixed it.

  • did a clean install of 0.5
  • then I enabled SSH on the webinterface.(restart)
  • then I used putty for login and did a atp-get update then a apt-get upgrade.
  • Then it was busy for a while and I typed reboot.

After that I tested spotify, online radio.
When I added a samba share it took some time for musicbox to start. about 15 min I think.
I waited and watched the cpu with “top” command in putty(ssh).
Then it looked fine.
When I changed my audio output I restarted. Wait for a long time because startup still takes a lott longer then without the samba share.
I watched the cpu and waited till it came to rest. Then I used musicbox.

Im not that good with the kernel and stuff, but now im hoping that someday my wolfson is going to work. Then its complete I think

1 Like

Do you have a lot of music in the samba share? If so, the indexing can be really slow.

hey thanks fella! this worked perfectly, now its fast!

I just started with Pi MusicBox this afternoon (Version 0.5 on Raspberry Pi B (512 MB)). Without any modifications I also see the message “Trying to reach MusicBox. Please wait…” when I open “musicbox.local” in my browser. Address changed from “musicbox.local” to “musicbox.local/#playlists”, in the left-hand navigation “Playlists” is highlighted. The behavior is identical for both Firefox and Internet Explorer.

When I select other entries in the navigation, the screen changes accordingly, but the popup message remains.
When I select “Settings”, I get “500 - Internal Server Error” (the popup disappears).
Where do I find log files, which may provide more details on the error?

I found this thread in the forum and tried to follow the suggestions but to no avail.
Here is what I did (after I observed the error in the browser):

  • looked for log files, but did not find any. When connecting the Raspberry Pi to my TV via HDMI, I can see that during the boot process there are a couple of error messages, which I cannot appraise though.
    Probably these messages are important. Is the output during the boot process captured in some log file?
  • “apt-get update” and “apt-get upgrade”, which updated 62 packages
  • enabled SSH in /boot/config/settings.ini
  • changed root password

I do not have any media on the Raspberry Pi, it is the pristine MusicBox image downloaded from and put on a 2 GB SD card using Win32 Disk Imager. The Raspberry Pi is connected to my LAN, no devices attached to the Pi.

I learned the “bootlogd” had to be installed in order to capture boot messages in “/var/log/boot”. Here I can see this:
root@MusicBox:~# grep -i error /var/log/boot
Sun Aug 31 19:29:19 2014: wlan0: ERROR while getting interface flags: No such device
Sun Aug 31 19:29:19 2014: Error for wireless request “Set Power Management” (8B2C) :
Sun Aug 31 19:29:22 2014: ^[[9;30]^[[14;30][…] Checking if shift key is held down:Error opening ‘/dev/input/event*’: No such file or directory
Sun Aug 31 19:29:34 2014: Error opening ‘/dev/input/event*’: No such file or directory
root@MusicBox:~# grep -i warning /var/log/boot

(I have neither a WLAN dongle nor a keyboard attached to my Raspberry Pi. This might explain the messages.)

Anything else I could check?

Edit 2:

Found a (maybe important) message in “/var/log/lighttpd/error.log”:

2014-08-31 19:02:38: (mod_proxy.c.1019) establishing connection failed: Connection refused
2014-08-31 19:02:38: (mod_proxy.c.919) proxy-server disabled: 6680 8
2014-08-31 19:02:38: (mod_proxy.c.1327) no proxy-handler found for: /Settings
2014-08-31 19:02:43: (mod_proxy.c.1372) proxy - re-enabled: 6680

Might this be a firewall-related issue (“Connection refused”)?

I cannot tell what it was, but as a last resort, I rewrote the SD card with the MusicBox 0.5 image once more and - guess what? - it just works!

So, apparently, a improperly written SD card can cause these “Trying to reach MusicBox.” effects…

Glad it worked in the end! There are problems indeed with some SD Cards.