[SOLVED] The continuing saga of Google Music(!)

Hi all,

I appreciate there are a few topics concerning not being able to log in to Google Music at the moment (I’m running PiMusicBox). I’m by no means an expert whatsoever, I can follow instructions but beyond that, I’ve no chance. I’ve tried following several different threads on how to fix the issue but nothing I try works and I invariably have to end up reinstalling PiMusicBox due to having tried something that stopped my ability to connect to the web based section.

So, my question here is: Do I wait it out because a fix WILL come in time - or has Google Music had its day and it’s time
for me to consider switching to Spotify? My wife uses and loves G.M. so I’m loathed to change anything but I really want to use PiMusicBox to its full potential.

Thanks for reading and as always, I really appreciate any help/tips/advice.


Can you describe the issue you’re having a little more? I have a similar issue wherein I enter the appropriate credentials and Google Music appears as an option available in the online platform, but neither the “Browse” nor the “Search” function work. I have tried supplying the DeviceID from my Android and also tried leaving the Device ID blank, but nothing seems to work.


Thanks for the reply. It’s directly related to this thread: Mopidy-Gmusic not authenticating whereby I’m not authenticating with Google. I’m aware there’s a problem and I’ve tried just about all the guides and how-to’s that I can find, but nothing works. I’m just hoping someone can either say I’m doing something wrong/wait for a fix/it’ll never work again…


Well by some means or another, I now have it working! I spent a few hours yesterday morning working through all the errors that were appearing in mopidy.log, updated, installed, edited and finally it’s all working perfectly. I would love to be able to post up a “Do this, then this, then that and it’ll work” but I did so many random things, I’m not sure what fixed it! However, I’ve been in touch with Wouter and have uploaded him an image of my SD card so I’m hoping he’ll be able to figure it out and maybe release the details :smile:

Mopidy-gmusic desperately needs a new maintainer. In the short-term it should hopefully get some attention to bring it back to working order and we’ll aim to include it in Musicbox v1.x. Beyond that it will need someone (who uses the service) to take over.

As things stand for me, it’s currently working perfectly and I’d be extremely hesitant to update or change any parts for fear of losing it again! I’ve made a clone of my card so if things do go wrong, I should be able to get it back again. I originally thought about switching over to Spotify - but only being able to use one device at a time is no good for me when I have the wife & kids all listening at the same time. It’s a no-brainer to stick with Google for this.

I’ve been trying to get hold of the GMusic maintainer for some days, and only today we got in contact. Mopidy-GMusic will be moving to the Mopidy organization at GitHub. I’m volunteering to get a 2 month trial subscription and with that get Mopidy-GMusic up to date and working again and get a new release out. After that, it is open for adoption by a maintainer that actually use Google Music day to day.


Awesome, @jodal. Thanks!

So, I didn’t bother trying with the Pi Musicbox image as it’s pretty old. However, using the latest Wheezy image, here are the exact steps I took to get it working.

wget -q -O - https://apt.mopidy.com/mopidy.gpg | sudo apt-key add -
sudo wget -q -O /etc/apt/sources.list.d/mopidy.list https://apt.mopidy.com/mopidy.list
sudo apt-get update
sudo apt-get install mopidy
sudo apt-get install python-dev
apt-get install python-pip && pip install --upgrade pip
apt-get install --upgrade setuptools
pip install --upgrade six
pip install git+https://github.com/hechtus/mopidy-gmusic.git@develop

Then modify your mopidy.conf as per the github instructions.

Doesn’t work for me…

I got a fail when trying to install python-pip, so did so using sudo

Also apt-get install setuptools didn’t work for me, so i did it using

wget https://bootstrap.pypa.io/ez_setup.py -O - | sudo python

Have modified my mopidy.conf file, and now mopidy seems to log in to gmusic, but when I select a track to play I get a “warning: track is not playable” error

I dont suppose anyone has a working image they can share (obviously without log ins and passwords).
I would really like to get Google Music functionality working. Deff a log in, authorisation issue for me. I am using device specific password (I use 2 step verification for my google account) and have set the device id etc No joy.



I’ve sent you a PM…

1 Like

with fresh mopidy, and install of mopidy-gmusic.git@develop i get auth error:
ERROR Failed to login as “mygoogleusername”

Hey Neil - you said somewhere before your found out the (iPhones?) device ID through chrome somehow - how did you do?

Also - you may know - will google music in pi musicbox work with the free version as well - or only with the paid like spotify?


to find the Device_ID, log into your Google Music account on PC/Mac, go to settings and then Devices (it may be ‘My Devices’). When you find that, just right click and Inspect Element - you’ll find your device_id in there. That’s how I found my iPhone ID :smile:

Another way I did it, was download an App on the wife’s Android (I can’t remember the name of it but there are a few on the store). Run that and you’ll get all the different ID’s - Android Device ID, Google Service Framework, IMEI etc., etc. I’m sure I used the Google Service Framework but I can check for you when I get home later.

Google Music will only work with an All-access (paid) account as far as I know.


1 Like

i tried both the android device id and GSF number.
same error:
ERROR Failed to login as “mygoogleusername”