Spotify connection issue

Hi all,

I have, like the title already suggested, issues accessing my Spotify (Premium) account. I enabled “playing music from Spotify”, added my Username, my Password and rebooted (all that several times), but it doesn’t work.
If I try to access any Spotify content I can’t find any tracks at all. Same in the search - if I select the filter for Spotify, I don’t get any results.

The only thing which seems a little off it this message while booting:
"(…) cannot check root file system because it is not mounted read-only (…)"

It would be great if you guys could help me fix this, because I really like the PiMusicBox a lot and if this will be fixed, it would be even more awesome!!!

Thanks a lot!

To address further questions you might probably have:
- PiMusicBox v 0.5.3
- Everything else works fine (Radio, Youtube etc.)
- I made sure that Username&Pw are correct
- I don’t connect via Facebook

If your spotify playlists are not appearing then there is a problem with the login.

  • Take a look for any warning messages in /var/log/mopidy/mopidy.log
  • Do you have any punctuation or weird characters in your username or password (a known musicbox bug)
1 Like

Thanks a lot!
I got rid of any special characters and all worked out fine!
– Problem solved –

Thanks! Removing underscore fixed everything