No spotify playlists, known fixes not working

Hi there!

For some reason, my musicbox pi does not show any of my personal spotify premium playlists.
I can listen to the top lists though.
I tried the fixes on the internet. But none of them worked.
As for some reason, in my config file of Mopidy, on the
[spotify] part. there is nothing set for Cache_dir: . I tried a rm -r /var/cache/mopidy/spotify to remove the cache but it doesn’t exist.
I also tried to delete var/lib/mopidy/spotify but that didn’t work either. Also tried a fresh reinstall.

I’m sorry if I’m missing something really obvious.

Topics with same problem I tried using.

I have a Terminal only Musicbox OS on my Pi.

Seemed I fixed it after using this solution:

This one works for me

1 Like

I have tried all fixes listed here and am still having no luck getting Playlists to load.

Running PMB 0.6 and Mopidy 0.19.5

There’s a v0.7.0 release candidate at you can try if you are interested. Please report any issues.

Thanks, I’ll check it out today.

Got the RC up and running. Seems to work but still has no Spotify playlists. As my installation is living solely for the purpose of Spotify, it’s not a huge help, but I can confirm that I got it running on an RPi 3 with no extra sauce needed.

Can you try restarting Mopidy? If you have a lot of playlists it needs time to load them all. You should be able to restart Mopidy from the command line with service mopidy restart or by enabling and disabling a random (non-Spotify) extension in the websettings.