Settings.ini overwritten?


I’ve been able to install pimusicbox from the .img download.

The issue is actually getting any local music. I have a share on an iMac that has lost of local music and I wish to access this. It’s not simple, but I’ve now found the correct format to either mount the directory using the mount command, or add it to fstab.

I initially added the iMAc address to the settings.ini - however there was an error in the share. Since then I’ve deleted the entries in web interface and added the correct setting in settings.ini using ssh to access the pimusicbox. But the settings.ini appears to keep getting overwritten when I reboot - so the mount fails.

I decided to approach this a different way, and added the mount to the fstab, and decided to ignore the settings.ini and the web interface, both of which I blanked. After a reboot the fstab doesn’t have the correct entry, and the wrong settings have appeared again in the web interface and the settings.ini.

I’m now lost, and very frustrated. What I’d like to do is have an entry in fstab that mounts my music correctly, and not have pimusicbox do anything. And am I correct in thinking that you can only have one network music share?


On boot it’ll read /boot/config/ and then in some cases it’ll change particulars lines, but never the mount_address/user/password lines.

The websettings just reads /boot/config/settings.ini, displays it in the form and then writes it all back out again when you click the button.

Nothing in pimusicbox touches /etc/fstab at all.

So considering all this I am also a bit lost.



I tried another sd card, and this seemed to fix the errors. Though there is a github issue that refers to fstab being overwritten.

I’ve now got PiMusicbox working on a pizero with an IQaudio zerodac

I’ve ignored the share settings in settings.ini and used fstab to mount my osx music share. my osx username has a space in, and this can be done in fstab using \040 for the space - it didn’t work in settings.ini

The first time I tried to use the new sd card I configured the IQaudio zerodac in settings, and got into a boot loop - i used the new setsound script described here Hifiberry amp2 continuous loop thru boot cycle and that got the audio card working and no subsequent loop.

It stutters a bit atm - but I’ll leave it for a while to scan my music. And I think the fstab entry can be refined.


Are you referring to That overwrites /etc/fstab when you build a pimusicbox image from the source code. You are not doing that, you said you downloaded the prebuilt .img.

I thought you could quote things in settings.ini to avoid problems like that but I admit I have not tried it specifically for the mount usernames.


Ah - ok - must admit I didn’t find it very clear what it was referring to.

Well, I couldn’t get it to work, perhaps I was using the wrong type of quotes. The fstab solution is pretty easy, and allows you to add extra options to the mount command - like noserverino, which the messages tell me I should be using!