Pi musicbox does not add network share with a space


I’m trying to access a linux machine with a samba share, with no success. After some troubleshooting I figured out that it was because there is a space in the path. So my share is like so:

// Collect

If I try and connect to another directory on that same server without spaces, it works fine and I can see the tracks. e.g.


I tried escaping the space in the pi musicbox settings, but this did not resolve the issue.

//\ Collect
//\ Collect

Any advice on how to resolve this would be much appreciated.


Seems like SMB is working different than URLs or the Linux file systems. In this discussion, they claim \040 instead of the blank does the trick:
Give it a try, if you haven’t resolved it yourself in the meantime. :wink: