Popcorn hour c-200 samba NAS

Greetings from Croatia! My name is Dražen and im trying hard to connect Pi Musicbox with Popcorn hour c-200 as samba share HDD NAS with 300GB flacs on it. Tried various combinations of suggested naming IP server name, adress, mounpoints, musicshares without any success. Everything else on pimusibox working fine and nice (internet radio, services) so i really dont want to go on Runeaudio, Volumino, Raspbmc, cause pimusicbox looks like the best!! My network file path looks like smb://pch-c200/share/Music, but when i enter it, simply dont work. Im not so familliar with programing, Linux, and so, but i spoted reported some 115 error (cant mount cifs, or something). Did anyone here experienced similar problems, and what would be easiest way to sove it? I would be gratfull on any advice, comment or suggestion! Thnx in advance! Sorry on my bad English!

Are you including the “smb:” prefix when you set the network__mount_address setting? I don’t think you want to be doing that.

The following command should be what musicbox is trying to do. Try running it yourself from the shell and then provide the actual error message you get. Don’t forget to fill in your network mount username (user) and network mount password (password) if you need to, otherwise leave them blank how they are:
mount -t cifs -o sec=ntlm,ro,user=,password=,uid=`id -u mopidy`,gid=`id -g mopidy`,iocharset=utf8 //pch-c200/share/Music /music/Network/

Thnx on quick replay, but unfortunately cant get it. Exact error is :
MusicBoxmount error:could not resolve address for pch-c200:Unknown error. My exact link to network is :/run/user/1000/gvfs/smb-share:server=pch-c200,share=share/Music. Maybe this will help to resolve problem? Sorry, by the way, what should i do with “mount -t cifs -o sec=ntlm,ro,user=,password=,uid=id -u mopidy,gid=id -g mopidy,iocharset=utf8 //pch-c200/share/Music /music/Network/”? Is this commant to tipe in root exactely like this, or should i change something?

You are trying to mount via GVFS which won’t work unless player understands GVFS urlis (they look like smb://pch-c200/share/Music in your case) an mopidy doesn’t support that.

You have two options: use one of the remote provider extensions (beets, subsonic) or mount using fuse fs via command @kingosticks provided. For info on that I recommend you to read https://wiki.archlinux.org/index.php/samba#Manual_mounting

Isn’t this musicbox (rather than mopidy) not supporting GVFS? Once it’s mounted on the file system then the uris will appear just like any other local uris to mopidy, won’t they? Am I missing something?

Edit: OK, I guess you don’t typically ‘mount’ gvfs to somewhere on your filesystem like normal, that’s the difference. So Yeh, mount it properly or go another route as @dz0ny suggested.

It actually turns out that there is gstreamer element gnomevfssrc which supports the following uris http, https, file, smb, ftp, sftp, ssh, dav. So if given an explicit URL it should just work if you add smb to the stream backends list of supported uri schemes. Though I have no idea how to pass along auth info in a sane way with this.

The bigger problem is however that you can’t point to a media_dir other than something which looks like plain local files, so the gnomevfssrc isn’t exactly a practical solution.

I think there is legacy mode, which sits in user home directory, but problem is that that is controlled by nautilus or other file managers not by the kernel. If nautilus crashes you lose connection for example and each file needs to be “launched” inside nautilus, to be available via legacy mode.

Edit: found it

Thnx to all! It looks like my IT mates will have some working here!!!

I dont know should that be important. On rune audio and Volumino to mount a Nas i have to type: ro,noatime,sec=ntlmv2 in mount section.?

Does it work when you replace pch-c200 with the ip address of your popcorn? The name resolving of Pi MusicBox 0.5 is not what it should be unfortunately. Will try to fix it in 0.5.1

Infact i did try and it didnt work.

    (in my case //…or /music?)
  2. NETWORK_MOUNT_ADDRESS = ‘//mynasserver/shared/music’
    (in my case //pch-c200/share/Music)
    To accsess on my network, there is also WORKGROUP folder. Should i type that somewhere?
    Tnx again i really like pimusicbox much so i would like it to work. But unfortunately im not god at all in root, configuring and compiling. When to be expect 0.5.1?

Hi again! Im happily announcing that (with minor corrections on IP adress numbers:)) popcorn NAS generally working with Pimusicbox)!! Generally? Well, some flac files in folders are missing. Then, cue files not supported as individual tracks? Then, album art while playing files are not showing? Other then that, Pimusicbox is really fantastic player! Grat work!

I’m having the same problem. This is whether I use my FreeNAS box from the uname or ipaddress. I also have a HDX (clone of the popcorn hour) and I just can’t get the mp3 list to show. The FreeNAS box is open, so doesn’t require a uname/pwd, the hdx does need uid/pwd and I have tested both from a windows box and both connect successfully.

PI Musicbox on a Raspberry Pi A or B (tried both)

Try to use pimusicbox 0.5.0. Its somehow solve this problems!

Hi, I actually switched to another distro, away from MusicBox, which just worked the second I tried it. I also have a basic web browser on my phone that MusicBox stated needed upgrading to interface, however, the new distro doesn’t have this limitation, so works well for me.

Are you talking about archphile maybe?

Hi, no, i didn’t want to say, but I’ve moved to volumio.

There may be other Mopidy webclients out there that are supported by more basic browsers. I’m not sure if that extends to anything that doesn’t at least support websockets.