Musicbox spotify playlists not there?

Hi folks
I just upgraded to version 5.1 after a fairly long absence. I have Spotify running quite nicely, however I do not know how to navigate to my playlists. I can search for music and play the top 100, but no luck finding my playlists. (clicking on “playlists” just produces a blank page)
Thanks for any assistance.

Take a look at

“Seems that this can also be fixed by removing the .config/mopidy/spotify directory, so it looks like a cache problem”

Thank you. I guess I’m not the only one. Unfortunately I am not the greatest at linux yet and I don’t quite understand what I need to do to clear this problem. I can’t even find the directory mentioned above in the quote on my raspberry PI.
Would appreciate any help. Thank-you

If you run service mopidy run config you should see where your Spotify cache directory is located. On your musicbox it should be the service default, /var/cache/mopidy/spotify. You can run rm -r /var/cache/mopidy/spotify to remove it and then restart Mopidy with service mopidy restart.

Thanks for your prompt response. When I run service mopidy run config the screen scrolls too fast and I can’t see the whole thing.When I went to /var/cache/mopidy it was an empty directory. The LS command didn’t show anything?

PS I am using musicbox on a raspberry pi. Txs for your help. Jim

Oh really? That's where mine is. You could run 'service mopidy run config | more' and then use space bar to go through the output one screen at a time.

Ok I found the directory. It was in /var/lib/mopidy/spotify. I removed it and restarted the service but no joy. It seems that the directory just gets recreated again. So maybe this is not the fix to this very annoying problem.Txs again and I hope you may have other ideas.

It will be recreated again when mopidy-spotify starts, and that’s what you want to happen. The theory being that the old one is somehow screwed up. It’s very weird this started happening to people and that it only works for some people.

Also /var/lib/mopidy/spotify should be the settings directory rather than the cache directory, was there actually a folder called Storage in there?

You are right, about the settings directory. It looks like no directory has been setup for the cache.cache_dir =settings_dir = /var/lib/mopidy/spotify

its just blank in the config file.

There is a spotify directory at /var/cache/mopidy/spotify. (not sure why I didn’t see it before) it does contain Storage, Users, and offline.bnk. I removed the spotify directory and restarted mopidy. I also set the cache_dir to point there. But still no joy.

I restarted mopidy yet again and bang the playlists appeared.???It seems its sorted out now. Rebotted the rapberry and all is still good. Soo txs for all you help !Jm

Hello. I also have a raspberry pi with musicbox and have the same problem. I have tried the above solution above with no luck. Also restarted the device a lot of times with no effect. Any idea on how to solve this problem? Everything worked great until only a few days ago.

Thanks to Kingo sticks, the following has been working for me

run rm -r /var/cache/mopidy/spotify to remove the cache and then restart Mopidy with service mopidy restart.

sometimes I need to do the restart twice. But its working!

A couple of users reported this. They also said it came back after a day or so. Strange!

For me it works only a the last step.
When I delete /var/lib/mopidy/spotify/

The following worked for me:

  1. Remove, or comment out, the cache_dir and settings_dir options from /boot/config/settings.ini
  2. Clean out all the old Spotify cache folders:
    rm -rf /var/lib/mopidy/spotify
    rm -rf /var/cache/mopidy/spotify
    rm -rf /root/.cache/mopidy/spotify
  3. Restart mopidy:
    service mopidy restart
1 Like

And then you uncommented those settings back in or left them out?

I’ve left them out, Spotify seems to default to a cache folder that way

I had the same problem.
When i run service mopidy run config there was no entry for the Spotify cache directory location.
The problem was solved when i manualy set the location (changing the /boot/config/settings.ini) to point in /var/lib/mopidy/spotify.

Thank you for the insight.

the solution of @nilicule does not work for me sadly :frowning: Did you add any settings to the spotify config?