Music Box not finding network files


#1

I just installed 0.6. I’m able to stream online radio stations and using Browse, Folders, USB I can find music files stored there. But I can’t see my NAS drive music files. Please help :smiley:


Streaming from Lacie 2BigNas
#2

it is possible that your NAS address is incorrectly inserted. If you want some one to help you, post your share folder name and show what you have in the field where you need to insert the address.


#3

My network drive IP is 10.0.0.14

I wrote //10.0.0.14/public/shared music into the settings file. Now I have another problem. It was streaming internet radio stations, but now there’s no sound at all.


#4

There was a regression in v0.6 where we no longer quote the server address so spaces cause problems. Can you try quoting the address in settings.ini i.e.

mount_address = "//10.0.0.14/public/shared music"

Or failing that, edit /opt/musicbox/startup.sh line 188 and quote the address there i.e.

mount -t cifs -o sec=ntlm,ro,user=$INI__network__mount_user,password=$INI__network__mount_password "$INI__network__mount_address" /music/Network/

#5

Thanks kingosticks. It’s been a while since I could get back to this. I changed my music directory from “shared music” to “music” but it still isn’t showing up when I browse local files, folders, network. It says “no tracks found.” I tried forward slashes and back slashes with no luck. I haven’t tried quoting the address in startup.sh because I took the whitespace out of the folder name. My network drive is under Windows 8.

Thanks!
Jeff


#6

Can I assume from Intermittent WUI connect failure that your files are appearing now?


#7

Yes, they WERE. All files were accessible, online services working. Well, the other day I changes out my wireless router (Comcast gateway) with an Apple Airport Extreme, putting the Comcast modem in bridge mode. The musicbox had no problem connecting to my laptop when I changed the password in Settings. But now, no NAS and no connection to Android devices (MPDroid).


#8

Oh yeah, and I CAN access the NAS through Windows Explorer on my laptop, so I know it’s visible


#9

I also can’t SSH into the pi anymore…


#10

I fought so much to get my external HD to work with PMB over the network and I failed at every attempt so what I did was I plugged my HD to my Netgear router and use it like that.

Netgear routers have this feature called Readyshare which automatically shares across the network any storage devices that are plugged into the router via USB.

This will make the storage device immediately available to any computer or device in the same network without requiring any authentication (which is not a problem if you’re using a private wifi network).

I put the network path of the HD (http://192.168.0.254/storage0)* in the PMB settings, left user ID and password settings blank and boom. Works like a charm.

The only problem is that browsing files on the HD from a computer using this method is PAINFULLY SLOW but the PMB has no problem browsing and playing back audio files.


#11

Well, since you’ve solved your problem, you are invited to reinforce your learning by helping somebody else solve their very similar problem … ahem: me!

Had no problems with the initial setup, and even managed to roll my own streams in streamuris … just can’t seem to get my network music folder hooked up.

Like you, I’ve dumped my music into a network share I created under readyshare with read and write for All.

My (abridged) settings looks like this:
[network]
wifi_network = xxxxxx
wifi_password = xxxxxxxxxx
name = MusicBox
mount_address = //readyshare/ActiveMusic
mount_user =
workgroup = WORKGROUP
enable_ssh = true
wait_for_network = true

[musicbox]
root_password =
resize_once = false
scan_always = true
autoplay = tunein:station:s6683
autoplaywait = 60

[local]
enabled = true
media_dir = /music
(Also tried pointing media_dir at mount_address with no discernable difference)
playlists_dir = /var/lib/mopidy/playlists
data_dir = /var/lib/mopidy/localdata

My (abridged) log file looks like this:
2015-11-19 21:42:22,392 - INFO Starting Mopidy 0.19.5
2015-11-19 21:42:25,095 - INFO Loading config from: builtin defaults, /etc/mopidy/extensions.d/spotify.conf, /etc/mopidy/mopidy.conf, command line options
2015-11-19 21:42:26,901 - INFO Enabled extensions: mopify, mpd, http, stream, spotify_tunigo, mobile, podcast-gpodder, local-sqlite, youtube, podcast-itunes, http-kuechenradio, simple-webclient, softwaremixer, local-whoosh, dirble, moped, websettings, podcast, local, tunein
2015-11-19 21:42:26,911 - INFO Disabled extensions: spotify, alsamixer, gmusic, scrobbler, subsonic, somafm, internetarchive, audioaddict, musicbox_webclient, soundcloud
2015-11-19 21:42:26,915 - WARNING Found alsamixer configuration errors, the extension has been automatically disabled:
2015-11-19 21:42:26,922 - WARNING alsamixer/control must be set.
2015-11-19 21:42:26,931 - WARNING alsamixer/card must be set.
2015-11-19 21:42:26,939 - WARNING Found musicbox_webclient configuration errors, the extension has been automatically disabled:
2015-11-19 21:42:26,942 - WARNING musicbox_webclient/musicbox unknown config key.
2015-11-19 21:42:26,951 - WARNING Please fix the extension configuration errors or disable the extensions to silence these messages.
2015-11-19 21:42:45,599 - INFO Found 0 files in media_dir.
2015-11-19 21:42:45,647 - INFO Checking 0 tracks from library.
2015-11-19 21:42:45,663 - INFO Removing 0 missing tracks.
2015-11-19 21:42:45,671 - INFO Found 0 tracks which need to be updated.
2015-11-19 21:42:45,677 - INFO Scanning…
2015-11-19 21:42:45,750 - INFO Scanned 0 of 0 files in 0s.
2015-11-19 21:42:45,786 - INFO Done scanning.
2015-11-19 21:42:50,225 - INFO Starting Mopidy 0.19.5

Completely stumped, think I’ve tried everything … no prior experience with Pi, but have hooked up FileZilla and can find my way around the file system okay now. In Windows Explorer my share is easily accessible as \readyshare\ActiveMusic and I can see and play all my files.

Help!

Dave

PS Edited because I bungled the share name in my posting, not in my settings.ini


#13

Hmm… when I was troubleshooting my external HD and PMB there would be an error message just before

2015-11-19 21:42:45,599 - INFO Found 0 files in media_dir.
2015-11-19 21:42:45,647 - INFO Checking 0 tracks from library.
2015-11-19 21:42:45,663 - INFO Removing 0 missing tracks

That would read something like “unable to mount drive (bad cifs)” or something of the kind.

Yours don’t show any errors so I wonder if mopidy is even trying to reach your hard drive.

2 things for you to try:

Leave “mount_address” blank in your settings.ini. Then in the PMB settings page type your the address to your share just like you had in the settings.ini (you might also want to try using the IP instead of readyshare as such //192.168.0.254/share)

Reboot PMB. If it works you should be able to browse your files by clicking browser > local media.

If that doesn’t work, try this:

In your PMB install cifs-utils (this is used to mount SAMBA shares in Linux)

sudo apt-get install cifs-utils

Edit the fstab file

sudo nano /etc/fstab

and add the following line

//readyshare/sharedfolder /music/Network cifs defaults,guest 0 0

and save

A few things to observe here:

/music/Network is a local folder in your Pi, it should already be there when you first install PMB. If not, simply create the folder or use another existing folder.

In the arguments following “cifs” there is no space in “defaults,guest”. Just copy the line as is to your fstab file.

Finally mount the network drive by running

sudo mount -a

If no error messages appear, it should have been mounted successfully.
You can check if it’s mounted by running

sudo df -h

This command shows all the current mounts. Your network share should be at the bottom of the list.

Edit the settings.ini one more time and uncomment the line
#scan_always = true

Reboot your pi and it should work. Be advised, the scan will take a long time if you have a lot of files. I have roughly 3000 songs on my HD and it took almost an hour to scan everything.
After the scan is completed and provided everything is working as it should go back to the settings.ini file and comment that line again.

Hope that helps! Good luck!


#14

9thFoot, where is your server name? your config does not have the server name at all…


#15

Jeff,

maybe the address changed (or some other network setting) due to the fact that you changed your network structure?


#16

Let’s put his down to a Senior moment! :o)

I can’t tell you how many times that I’d already tried //IP.Address instead of //readyshare … if only I’d been using the correct IP address! As soon as I corrected that, I was rewarded with:

2015-11-21 17:15:06,645 - INFO Scanned 2101 of 2101 files in 815s.
2015-11-21 17:15:08,690 - INFO Done scanning.

So, my (further abridged) settings now looks like this:


[network]

mount_address = //192.168.1.22/ActiveMusic
mount_user =
mount_password =


[local]
enabled = true
media_dir = /music
playlists_dir = /var/lib/mopidy/playlists
data_dir = /var/lib/mopidy/localdata

Thanks, very much for the feedback, which prodded me back in the right direction!


#17

W00t W00t!

Glad you got it working. :sunglasses:


#18

I hope somebody can help me with a similar problem. The network share seems to get mounted as I can browse the directory over ssh, but the web interface doesn’t show any files.
The log shows that for some reason mopidy doesn’t have permission to read the directory.
2015-11-24 17:21:30,213 - ERROR Error browsing local:directory:Network: [Errno 13] Permission denied: '/music/Network'
What can be done to fix this? Sorry if this is a noob question.


#19

Sounds like a permissions issue.

try this command:

sudo chmod 755 /music/Network

If that doesn’t work (and as last resort only) run:

sudo chmod 777 /music/Network

Check this link for an explanation on permissions on Linux.


#20

Thank you for trying to help, but the problem persists, even with the maximum folder permissions. I don’t know if it is relevant, but the system replied with: chmod: changing permissions of '/music/Network': Read-only file system when changing the permissions.

The most recent log reads:
2015-11-25 12:13:34,638 - INFO Starting Mopidy 0.19.5 2015-11-25 12:13:38,792 - INFO Loading config from: builtin defaults, /etc/mopidy/extensions.d/spotify.conf, /etc/mopidy/mopidy.conf, command line options 2015-11-25 12:13:40,562 - INFO Enabled extensions: mopify, mpd, http, stream, spotify_tunigo, mobile, podcast-gpodder, local-sqlite, youtube, podcast-itunes, http-kuechenradio, simple-webclient, softwaremixer, local-whoosh, dirble, moped, websettings, podcast, local, tunein 2015-11-25 12:13:40,571 - INFO Disabled extensions: spotify, alsamixer, gmusic, scrobbler, subsonic, somafm, internetarchive, audioaddict, musicbox_webclient, soundcloud 2015-11-25 12:13:40,578 - WARNING Found alsamixer configuration errors, the extension has been automatically disabled: 2015-11-25 12:13:40,590 - WARNING alsamixer/control must be set. 2015-11-25 12:13:40,593 - WARNING alsamixer/card must be set. 2015-11-25 12:13:40,596 - WARNING Found musicbox_webclient configuration errors, the extension has been automatically disabled: 2015-11-25 12:13:40,611 - WARNING musicbox_webclient/musicbox unknown config key. 2015-11-25 12:13:40,614 - WARNING Please fix the extension configuration errors or disable the extensions to silence these messages. 2015-11-25 12:13:59,102 - INFO Found 0 files in media_dir. 2015-11-25 12:13:59,154 - INFO Checking 0 tracks from library. 2015-11-25 12:13:59,168 - INFO Removing 0 missing tracks. 2015-11-25 12:13:59,178 - INFO Found 0 tracks which need to be updated. 2015-11-25 12:13:59,187 - INFO Scanning... 2015-11-25 12:13:59,288 - INFO Scanned 0 of 0 files in 0s. 2015-11-25 12:13:59,342 - INFO Done scanning. 2015-11-25 12:14:04,136 - INFO Starting Mopidy 0.19.5 2015-11-25 12:14:06,224 - INFO Loading config from: builtin defaults, /etc/mopidy/extensions.d/spotify.conf, /etc/mopidy/mopidy.conf, command line options 2015-11-25 12:14:07,925 - INFO Enabled extensions: mopify, mpd, http, stream, spotify_tunigo, mobile, podcast-gpodder, local-sqlite, youtube, podcast-itunes, http-kuechenradio, simple-webclient, softwaremixer, local-whoosh, dirble, moped, websettings, podcast, local, tunein 2015-11-25 12:14:07,928 - INFO Disabled extensions: spotify, alsamixer, gmusic, scrobbler, subsonic, somafm, internetarchive, audioaddict, musicbox_webclient, soundcloud 2015-11-25 12:14:07,932 - WARNING Found alsamixer configuration errors, the extension has been automatically disabled: 2015-11-25 12:14:07,935 - WARNING alsamixer/control must be set. 2015-11-25 12:14:07,937 - WARNING alsamixer/card must be set. 2015-11-25 12:14:07,940 - WARNING Found musicbox_webclient configuration errors, the extension has been automatically disabled: 2015-11-25 12:14:07,943 - WARNING musicbox_webclient/musicbox unknown config key. 2015-11-25 12:14:07,946 - WARNING Please fix the extension configuration errors or disable the extensions to silence these messages. 2015-11-25 12:14:25,298 - INFO Starting Mopidy mixer: SoftwareMixer 2015-11-25 12:14:25,304 - INFO Mixing using GStreamer software mixing 2015-11-25 12:14:25,318 - INFO Mixer volume set to 85 2015-11-25 12:14:25,321 - INFO Starting Mopidy audio 2015-11-25 12:14:25,340 - INFO Starting Mopidy backends: SpotifyTunigoBackend, TuneInBackend, LocalBackend, StreamBackend, PodcastBackend, YoutubeBackend, DirbleBackend 2015-11-25 12:14:25,682 - INFO Audio output set to "alsasink" 2015-11-25 12:14:25,759 - INFO Loaded 0 local playlists from /var/lib/mopidy/playlists 2015-11-25 12:14:25,781 - INFO Loaded 0 local tracks using sqlite 2015-11-25 12:14:25,975 - INFO Starting Mopidy-Podcast directories: iTunesDirectory, FeedsDirectory, GPodderDirectory 2015-11-25 12:14:26,010 - INFO Refreshing Mopidy-Podcast directories 2015-11-25 12:14:26,074 - INFO Starting new HTTP connection (1): itunes.apple.com 2015-11-25 12:14:26,167 - ERROR Refreshing Mopidy-Podcast-iTunes failed: ('Connection aborted.', error(101, 'Network is unreachable')) 2015-11-25 12:14:26,203 - INFO Starting Mopidy core 2015-11-25 12:14:26,535 - INFO Starting Mopidy frontends: MpdFrontend, HttpFrontend 2015-11-25 12:14:26,551 - INFO MPD server running at [::ffff:0.0.0.0]:6600 2015-11-25 12:14:26,570 - INFO HTTP server running at [::ffff:0.0.0.0]:6680 2015-11-25 12:14:59,915 - INFO 304 GET /images/icons/play_alt_32x32.png (192.168.2.110) 117.51ms 2015-11-25 12:15:19,547 - INFO 304 GET /images/icons/play_alt_32x32.png (192.168.2.110) 11.54ms 2015-11-25 12:15:27,122 - INFO New MPD connection from [::ffff:127.0.0.1]:55003 2015-11-25 12:18:21,769 - INFO 200 GET / (127.0.0.1) 23.25ms 2015-11-25 12:20:21,832 - INFO 200 GET / (127.0.0.1) 15.61ms 2015-11-25 12:22:21,895 - INFO 200 GET / (127.0.0.1) 15.41ms 2015-11-25 12:24:21,959 - INFO 200 GET / (127.0.0.1) 14.95ms 2015-11-25 12:26:22,021 - INFO 200 GET / (127.0.0.1) 15.71ms 2015-11-25 12:28:22,084 - INFO 200 GET / (127.0.0.1) 15.27ms 2015-11-25 12:29:18,787 - ERROR Error browsing local:directory:Network: [Errno 13] Permission denied: '/music/Network' 2015-11-25 12:30:22,150 - INFO 200 GET / (127.0.0.1) 15.17ms

From what it looks like to me it seems that mopidy doesn’t even try to open the directory to scan it until I try to open it though the web interface. I did check that it was mounted beforehand, but apparently it still doesn’t load in correctly.


#21

Is the scan_always setting in settings.ini set to true? If not, can you set it to true, reboot the Pi and see if it works?