Last 25 radio stations not visible

Since trying version 0.5.3 with no luck (won’t appear on the network) I’ve moved back to 0.5. By that I mean I’ve reformatted the sd and reinstalled musicbox0.5.img.
But now the Radio menu list of the last 25 stations is empty. Even when I play/save an entered url the entered station doesn’t appear in the list field.
I’ve read the related threads here but deleting cookies/cache seems to have no effect.

You can also apparently add streams permanently to
/opt/defaultwebclient/js/streamuris.js. that way they will always be listed (not only in the browser). When you update you can migrate this file, and they should come along. If you are unable to get the new version 0.53 to get online, maybe you should move the old config.txt file (which has your network settings) to the new one?

I’m not sure I understand your last suggestion. Are you saying I should save a copy of /boot/config.txt from the 0.5 installation to the same place in the 0.53 installation?

FYI we are very willing to try and help debug and fix any problems with 0.5.3 but probably unable to help with older versions.

thanks for the offer kingosticks. i’ll reinstall and let you know if it shows up on my network this time. if it doesn’t i’d be very grateful for your suggestions

Since the necessary information for the device to go online is stored in that setup file and you already have one version that is working, I was suggesting copying the old file to the new install. I claimed that the file is config.txt, but actually after I relooked, I now notice that it is actually called settings.ini. When you enter settings from the browser gui, it edits this file, which you can also edit manually with a text editor. I had to do this, since I set up a headless device with no free usb-ports. In this scenario one cannot access the GUI from the browser, nor SSH in, since the device does not even have the network credentials. So, I took the sd-card, put it into a laptop,I edited the file settings.ini manually inserting the credentials, and then put the card in the Pi and booted. Worked just fine and the Pi appeared on the network on first boot. The settings.ini file is identical in the versions 0.53 and 0.52 at least, and perhaps even earlier, since the manual for 0.4 that is on the website seems to be using the same file. As currently one cannot update MusicBox in any other way except reflashing the sd-card, updating always means loosing all previous settings. Unless one migrates the files that contain the settings.

i’ve reinstalled 0.5.3 and replaced /boot/config.txt with that from 0.5 and the rasPi now appears on the network.
But now when I try to connect via ssh -l root i get this error:

Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /Users/haroldfeist/.ssh/known_hosts to get rid of this message.
Offending RSA key in /Users/haroldfeist/.ssh/known_hosts:7
RSA host key for has changed and you have requested strict checking.
Host key verification failed.

Since you’ve reinstalled the system, this is what is happening here.

The solution is to remove line 7 of the above mentioned file.

that did the trick! deleted the old entry for that address and all works a-ok now. thanks so much for the help!