Problems with editing (adding stations to) /boot/config/streamuris.js [solved]

First things first… What a brilliant idea, the Pi MusicBox! Thanks! It was just what I was looking for :smiley:

Now… About that /boot/config/streamuris.js

While browsing, I learned that streams added through the webinterface (musicbox.local/#stream), are stored in a cookie in the browser.

But I wanted to see the same stream list on any kind of device, so it made sense to just edit streamuris.js.
So I copied streamuris.js to streamuris.js.old, and then replaced the original stream addresses in streamuris.js with a small list with TuneIn radio stations I compiled. Like so:

streamUris.push(['Slam! The Boom Room', 'tunein:station:s253880']);

Now, with my new list loaded, no streams whatsoever are being shown on the Streams page.
Putting back the original list, the original list is being shown.

So the question is; is it even possible to have TuneIn stations in streamuris.js?
If so, is the syntax I’m using correct?


instead of moving the file, try editing it. this is not a “real file” but a link to the real file elsewhere.

Thanks for your comment.

However… I never said I moved anything. I said I made a copy (backup) of the original file, so I could indeed just edit the original file.
And this is the “real file”. If you’re talking about the symlink, I found that one over here: /opt/webclient/js/streamuris.js.

Thanks anyway.

Problem solved… It works like it should now.

I just kept staring at the stream list I created, just to see whether or not I missed something. And it turns out I did miss something.

I also had these listed:

streamUris.push(['Radio Veronica 80's Hits', 'tunein:station:s242550']);
streamUris.push(['Radio Veronica 90's Hits', 'tunein:station:s100916']);

10 points for anyone who sees what went wrong here :stuck_out_tongue:

1 Like

We don’t do anything to check the contents of what you put in the file so it’s not the most user-friendly setup. I would have thought you would get a javascript error in the developer console of your web browser, but even if you do, I appreciate most people wouldn’t know to look there. If we have this in the next release (which we very likely won’t) perhaps we can do something to better alert users of the javascript error.

And just in case anyone else ends up here with a similar issue: the problem is with the use of a ' character in the station name. Thanks for coming back and letting us know what was wrong - I’ll split those points with you.