Installing tp link wn823n, driver problem


#1

I recently installed the pimusicbox software on my Pi1. In order to use the wifi I have the tplink wn-823n wifi dongle. My Kernel Version is 4.14.26+. When I check my USB devices via lsbusb I am getting this

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 2357:0109  ** <- WiFi Dongle **
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub

The marked one is the wifi dongle. I already tried installing the drivers via the installation tutorial in the drivers.zip. Now I haven’t tried modifying the kernel source because the dongle should work with my kernel. So I skipped that step. But I’m getting errors at the last make at 2.2. (Page 8 in the pdf). The make clean worked without errors.

> make ARCH=arm CROSS_COMPILE= -C /lib/modules/4.14.26+/build M=/tmp/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047  modules
> make[1]: *** /lib/modules/4.14.26+/build: No such file or directory.  Stop.
> Makefile:1828: recipe for target 'modules' failed
> make: *** [modules] Error 2

The Error of the make command


#2

This was resolved using the script at http://downloads.fars-robotics.net/wifi-drivers/ as described here.