Accessing USB files on the Pi under Networks in Windows

When I installed Volumio on my Pi2B I could copy and past music files from Windows file explorer to the network drives (USB sticks) on the Pi.

With Musicbox all I get is one folder appearing in Windows as shared. So I can copy and past music files from Windows to my Pi USB drives how do I make the USB sticks appear in files explorer?

Have you tried WinSCP?

What is it and how does it work and where do you run it.

“WinSCP (Windows Secure Copy) is a free and
open-source SFTP, FTP, WebDAV and SCP client for Microsoft Windows. Its
main function is secure file transfer between a local and a remote

Install on your Windows pc, open it, enter the IP address and login details of the Musicbox you want to communicate with, I leave port as 22, it then opens up like windows explorer and you can drag and drop files between the two.
I find it works better using SCP rather than default SFTP from the drop down box.

Steve do up you use Musicbox on a Pi and are you files local to the Pi?

Yes I use Musicbox on a Pi.
Yes I have some mp3 files in the Musicbox folder on the Pi.
I also have more mp3 files on a usb stick that is plugged into the Pi.
I can’t access the USB stick when using Windows Explorer - therefore I use WinSCP to move files between the Windows PC and the USB stick on the Pi.
However before they actually appear to play on the Pi (in the Browse - Local Media) I think you need to go to Settings > Music files > Turn on the ‘Scan Music Files’ option then reboot.They should then show up in Browse - Local Media.
If you are having problems seeing the files you are adding I would suggest you just add one or two to begin as it can take a while to scan them.


MusicBox does offer a plain network share out of the box.
I don’t remember what folder is shared by default, though.

Check out /etc/samba/smb.conf and look for the [Music] block.

Mine looks like this:

path = /music
comment = Directory for music files
writable = yes
browseable = yes
guest ok = yes
create mask = 0777
directory mask = 0777
follow symlinks = yes
wide links = yes

The network share listing looks as follows:

Unfortunately, there is no watchdog to automatically scan the music folder for changes. So you currently either have to reboot or log in via SSH and trigger a rescan.

Hope this helps.


Hi Jochen, how do I set it to share? In the /etc/samba/smb.conf file I only have 2 lines
As it is I only get the same as mwhouston, just one folder.

Thanks a lot - got it sorted out, I found it on another Musicbox, the /etc/samba/smb.conf file was as follows

path = /music/MusicBox
comment = Directory for music files
writable = yes
browseable = yes
guest ok = yes
create mask = 0777
directory mask = 0777

I changed it to the same as yours and it now shows all folders in Windows Explorer.