Very high volume and boot failure on v0.6

Hey guys, just wanted to report a couple of things.

  1. I use a USB DAC and the volume is deafening, I have to keep it below 5 using my headphones
  2. As a result I wanted to try to switch to the other volume control method. However, changing the setting from software to alsamixer causes the unit to not start the webserver

I’ve tried setting card = 1 and the other setting Master but it still doesn’t boot. I can use the unit in software mode just need to be careful not to let to volume go too high.

When switching to a hardware mixer did you try the suggestions in the
settings.ini comments? Usually one of the controls works.

When I do the amixer scontrols I get
Simple mixer control ‘PCM’, 0

Right now I have Control set to Master

And what happens when you set control = PCM ?

I put
mixer = alsamixer
control = PCM
card = 0 and 1

All the settings, seems as soon as mixer is not software, cause the thing to report the same issues and prevents the web server from loading

Can I presume you put each of those settings in the correct config section? If mopidy is not starting due to a config problem then it should report the issue in /var/log/mopidy/mopidy.log


mixer = alsamixer

card = 1
control = PCM

Well good sir… No I feel the fool. It is possible that this is the mistake I was making which then prevented the web server from starting. I double and triple checked and the system of course booted properly and volume is much much much better.

Thank you and sorry for the confusion

No problem at all. settings.ini is getting so big it’s very easy to run into issues like that. Hopefully in the future we can do something to make the mixer settings easier to change, at least from the websettings. Or at least work out why it’s deafening for some people and very quiet for others.