Using Google Music


I used to use PiMusicbox with Spotify and it worked perfectly. I haven’t used it in a little while but have just signed up for a Google Music account. I tried adding my details in the settings but it doesn’t seem to work. I’m running an older 0.4 version and am wondering if I update to 0.5, will it fix it (haven’t done so yet because my sd card reader has packed up!)? I put my username and password in, I don’t have an android so can’t fill in the device id.

Thanks for any help :slight_smile:

I believe that Google Music was fixed to work again in 0.5 Beta 2.

1 Like

Brilliant. Thanks very much for the reply. I’m off to buy a new card reader today and will try the new version tonight.

Thanks again,

Hi again.

So I got the new card reader, set PiMusicBox up on it. Edited the settings.ini to include my Google Music username and password, left the device id blank as I don’t know what it is (I don’t have an Android device), rebooted the Pi and it all started. Using a browser, I can connect to it no problem, I can see my Google playlists etc. But…When I select a song from a playlist, it starts playing but no sound. I spent ages trawling around for a solution, tried a few things but nothing worked. I happened to try clicking on radio and I instantly got sound. I then noticed if I search for a song/album/artist, nothing is found. So I think it must be some kind of problem connecting to Google Music and am wondering if I need to fill in that device id? After more trawling it looks like I need to put my iPhone’s UDID preceded with ‘ios:’ - does anyone know if this is likely to be the problem? I’ll try it later but I didn’t stumble upon this possible solution until late last night after I’d turned everything off…


Well I tried putting in the device number by following some instructions I found - open Google Music in Chrome, go to devices, select my iPhone, right click, inspect element and copy the line starting “ios:”. Rebooted, still no sound or search. Removed password (don’t have 2 way verification) rebooted and lost playlists, put password back in and still nothing. I’m bemused! Will keep trying different things.

Update: Finally managed to get music playing! I went into Chrome again and found another iOS number. My wife and I both use Google Music on our iPhones and I’m guessing this iOS number was her device id - either way it worked. However, I can only play songs from her playlist. When I go to search and try something, I only get hits back from Podcasts. Nothing in Artists or Albums - so search doesn’t seem to actually search Google?? Feel like I’m so close to getting it all working.


I’m surprised that didn’t work, judging from it looks supported. Do you need to also set all_access = true to get search results?

Thanks again for the reply. I’ll be most embarrassed if that’s the answer! Yet again I’m away from home now but will have a look later tonight.

Really appreciate the replies :slight_smile:

Hi again.

I tried editing the settings.ini for PiMusicBox and adding line - all_access = true in the Google Music section, started it up and now the playlists have disappeared…Do you know if I’m putting it in the wrong place?

All settings go in there so that would be the place.

I don’t have an all access subscription and I don’t personally use gmusic so I don’t know what the difference is between all access, different people’s playlists (!) and what can/can’t be searched. Maybe there is something in the Mopidy log reporting what’s going on here. Failing that, and no further ideas here, you could try and reach the extension author (

There is also a gmusic all access bug reported by the Pi Musicbox author, perhaps it’s not actually fully working again…?

Ok, that’s cool. Once again, thanks for the reply. The wife is at work tonight so I’ll be able to spend sometime going through it and try various things. Will look thru the logs and see what’s going on. I’ll post up any findings…


Played around for a few hours tonight but got no further. I think I’m going to have to accept that maybe search just isn’t working properly at the moment. Real shame because it’s so close to being perfect! I’ll keep checking for any updates (to this thread or to PiMusicBox itself).


Search is not well supported by the gmusic extension that is in musicbox 0.5. That’s one of the things why it’s beta… I don’t know if iOs device id’s would work. Maybe try with an id from an android device?

Hey Wouter :smile: I’ll try and find a device and see how it works. For now, I still have it working - I suddenly realised yesterday that PiMusicBox supports Airplay so I just use Google Music on my iPhone and Airplay to it for now. Works just brilliantly!

You could try this image for better Google Music support:
it’s really early, the Settings page does not work, but Google Music works better (over here at least…)

Cool. Thanks a lot, will give it a go.

I meant to say earlier, the wireless settings are working really well now. You may remember around Christmas time I sent you a PDF of everything I had to do to get my USB wireless adapter working - now though, I just enter my details in the settings.ini and it connected straightaway.

My wife and kids are loving being able to stream straight from their phones - the wife thought it was fantastic being able to sit in the garden and choose the music coming from the house!

Thanks! Glad to hear these things!