Trouble getting Web Extensions/API Explorer Installed


#1

I’m running mopidy on a mac and I’m unable to get either the explorer any web extensions to run. I’ve installed Moped and Mopify using sudo pip install ... commands and I don’t receive any errors.

When I visit localhost:6680, I don’t see the links to to the API Explorer or other installed web extensions like I should. Is there something wrong with my config file?

# For further information about options in this file see:
#   http://docs.mopidy.com/
#
# The initial commented out values reflect the defaults as of:
#   Mopidy 2.1.0
#   Mopidy-File 2.1.0
#   Mopidy-HTTP 2.1.0
#   Mopidy-Local 2.1.0
#   Mopidy-M3U 2.1.0
#   Mopidy-MPD 2.1.0
#   Mopidy-SoftwareMixer 2.1.0
#   Mopidy-Spotify 3.1.0
#   Mopidy-Stream 2.1.0
#
# Available options and defaults might have changed since then,
# run `mopidy config` to see the current effective config and
# `mopidy --version` to check the current version.

[core]
#cache_dir = $XDG_CACHE_DIR/mopidy
#config_dir = $XDG_CONFIG_DIR/mopidy
#data_dir = $XDG_DATA_DIR/mopidy
#max_tracklist_length = 10000
#restore_state = false

[logging]
#color = true
#console_format = %(levelname)-8s %(message)s
#debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n  %(message)s
#debug_file = mopidy.log
#config_file =

[audio]
#mixer = software
#mixer_volume = 
#output = autoaudiosink
#buffer_time = 

[proxy]
#scheme = 
#hostname = 
#port = 
#username = 
#password = 

[mpd]
#enabled = true
#hostname = 127.0.0.1
#port = 6600
#password = 
#max_connections = 20
#connection_timeout = 60
#zeroconf = Mopidy MPD server on $hostname
#command_blacklist = 
#  listall
#  listallinfo
#default_playlist_scheme = m3u

[http]
enabled = true
hostname = 127.0.0.1
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

[stream]
#enabled = true
#protocols = 
#  http
#  https
#  mms
#  rtmp
#  rtmps
#  rtsp
#metadata_blacklist = 
#timeout = 5000

[m3u]
#enabled = true
#base_dir =
#default_encoding = latin-1
#default_extension = .m3u8
#playlists_dir =

[softwaremixer]
#enabled = true

[file]
#enabled = true
#media_dirs = 
#  $XDG_MUSIC_DIR|Music
#  ~/|Home
#excluded_file_extensions = 
#  .jpg
#  .jpeg
#show_dotfiles = false
#follow_symlinks = false
#metadata_timeout = 1000

[local]
enabled = false
#library = json
#media_dir =
#scan_timeout = 1000
#scan_flush_threshold = 100
#scan_follow_symlinks = false
#excluded_file_extensions = 
#  .directory
#  .html
#  .jpeg
#  .jpg
#  .log
#  .nfo
#  .png
#  .txt

[spotify]
enabled = true
username = x
password = xxx
client_id = xxx
client_secret = xxx
bitrate = 320
#volume_normalization = true
#private_session = false
#timeout = 10
#allow_cache = true
#allow_network = true
#allow_playlists = true
#search_album_count = 20
#search_artist_count = 10
#search_track_count = 50
#toplist_countries =

[mopify]
enabled = true
debug = false

#2

Hi.
You have to change the settings in mopidy config in the http section. The hostname must not be 127.0.0.1 because with this setting you can only access the web interface on the device. I’m not sure if you should set it to 0.0.0.0 or to the iP your raspberry has. In the moment I have no raspberry to look at my settings.
Good look

https://docs.mopidy.com/en/latest/ext/http/


#3

Same issue on OSX. Changing ip to 0.0.0.0 didn’t fix the problem


#4

The command mopidy deps will show you the extensions that have been found and the paths that are being used. The OSX documentation has a note about the PYTHONPATH needing to be corrected if using OSX bundled python, could this be the issue?

And yes, this issue is unrelated to the configured hostname, nor Raspberry Pis.


#5

Have the same issue here. Installed mopidy with brew, installing extensions with sudo pip install and it seems that Mopidy cannot see any of the installed extensions.

It might have something to do with sudo and where they are getting installed versus where Homebrew installed Mopidy, but pip seems to see that Mopidy is installed, so I don’t know…