Can't seem to Get Mopidy to Work (newbie) (SOLVED)


#1

Hello,

Please new here and trying to manually install Mopidy on my Raspberry Pi 3 manually. I have made all successfully installed it, ran it as a service and it reports back fine. But I don’t seem to be able to access it over the web interface.

I installed The Music Box Extension , tried to connect over the network using port 6680 but to no avail. My [http] config is as follows:

[http]
enabled = true
hostname = 0.0.0.0
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

When I start the service, I get the following

INFO     Starting Mopidy 2.1.0
INFO     Loading config from builtin defaults
INFO     Loading config from /home/pi/.config/mopidy/mopidy.conf
INFO     Loading config from command line options
INFO     Enabled extensions: iris, mpd, http, stream, m3u, musicbox_webclient, softwaremixer, file, local-images, websettings, tunein
INFO     Disabled extensions: spotify, local
WARNING  Found local configuration errors, the extension has been automatically disabled:
WARNING    local/media_dir must be set.
WARNING  Found spotify configuration errors, the extension has been automatically disabled:
WARNING    spotify/username must be set.
WARNING    spotify/client_secret must be set.
WARNING    spotify/password must be set.
WARNING    spotify/client_id must be set.
WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO     Starting Mopidy mixer: SoftwareMixer
INFO     Starting Mopidy audio
INFO     Starting Mopidy backends: TuneInBackend, StreamBackend, M3UBackend, FileBackend
INFO     Audio output set to "autoaudiosink"
INFO     Starting Mopidy core
INFO     Starting Mopidy frontends: IrisFrontend, MpdFrontend, HttpFrontend
INFO     Starting Iris 3.8.6
INFO     MPD server running at [::ffff:0.0.0.0]:6600
INFO     HTTP server running at [::ffff:0.0.0.0]:6680
INFO     Starting GLib mainloop
INFO     Creating dir /home/pi/.local/share/mopidy/local-images

Please any help will be very much appreciated.

Regards


#2

You say you are connecting over the network, I assume local and you can ping the mopidy server at whatever IP address? The raspberry doesn’t have a firewall running (doesn’t by default)?

FWIW, it looks like it starts and is listening on the 0.0.0.0 which defaults to all IP addresses. So check that your client can ping that ip.


#3

Hello @tschmidty69,

Thanks for the response.

Yes I am local and I am connected over ssh. I can ping it, but it still doesn’t come up. Do you think I am missing something so far? I can upload more logs if need be.

Kind regards


#4

what do yo type into to the browser to access mopidy ?


#5

Hello @mczerski,

Apologies for the late response. I type on my browser 192.168.0.32:6680.

I have tried other ways with port 80 or when I installed the music box web extension, tried 192.168.0.32:6680\musicbox_webclient as advised and still nothing works.

Please want to get this this stuff to work, but I am so confused what’s the issue.

Kind regards


#6

I think it should be a forward /

Can you connect to iris http://192.168.0.23:6680/iris/#/

If running as a service shouldn’t your mopidy.conf file be at /etc/mopidy/mopidy.conf - in your post above it is looking for the .conf file at /home/pi/.config/mopidy/mopidy.conf


#7

@Steve_Lambert,

Thanks for the response.

That didn’t still work

Yeah that’s what happens, and to be honest my /etc/mopidy/mopidy.conf file doesn’t have much.

Regards


#8

So back up your /etc/mopidy/mopidy.conf file then try and save your /home/pi/.config/mopidy/mopidy.conf as /etc/mopidy/mopidy.conf then reboot. Or copy and paste everything in /home/pi/.config/mopidy/mopidy.conf into /etc/mopidy/mopidy.conf


#9

@Steve_Lambert,

I will do as said, but I just noticed something interesting. I just ran the command sudo mopidyctl config and to my surprise it gave out the following

[mpd]
enabled = true
hostname = 127.0.0.1
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
  listall
  listallinfo
default_playlist_scheme = m3u

[http]
enabled = true
hostname = 127.0.0.1
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

This is regardless of me changing the hostname to 0.0.0.0 in my config. Let me try your suggestion and hopefully that should solve it.

Get back to you soonest and kind regards


#10

@Steve_Lambert,

That did it, thanks mate.

@tschmidty69 and @mczerski thaks for all the contributions. Now I know new stuffs :slight_smile:

Will close this thread now.