Mopidy Discourse

Accsessing the http frontend

I’m trying to make the http interface work. What I get is a few lines like this:

Web clients which are installed as Mopidy extensions will automatically appear here.

but nothing else.

I have this effective config:

[http]
enabled = true
hostname = ::
port = 6680
zeroconf = Mopidy HTTP server on $hostname
allowed_origins = 
csrf_protection = true
default_app = mopidy

I have spotify and local file backends installed, which works with mpc.

Forget it. I figured it out myself.

Did you try doing sudo mopidyctl deps to see the extensions that can be found? I thought i added that to the forum post template but maybe it’s no longer showing…

How exactly did you install the Web frontend extensions? Are you running as a service?

What did you do to fix it?

I actually installed Iris. I’m sorry, the problem was between the chair and the keyboard. :slight_smile:

I had to install using pip, as this isn’t available as a debian package. I am on Debian stable (well acually MX Linux)

Not this topic, but I had to change the user and the group to root at the startup script to make mopidy start automatically.

No idea what MX Linux is but I’m going to assume that’s an MX Linux specific workaround. The normal service file should work as-is with regular Debian. I have to say this as people inadvertently find posts like this and blindly make similar changes which are usually wrong.

MX Linux is a midweight OS based on Debian stable. Well, I’m sorry, maybe it should work as it is, but for me I had to tweak it a little bit. Anyways… people who do random things blindly would never work it out how to change the effective UID of a daemon.

Often these things come with example modifications and people blindly use those.

No need to apologise, I appreciate you’ve taken the time to reply and I’m only trying to avoid extra work for my future self by heading this one off early.

Hello,

I think I have the same problem.
I have installed on Debian 10 from apt get.
And all the extensions from pip3.

If I run Mopidy as an service and use the conf fil from /etc/mopidy things starts but I don’t get the web interface. only:

Mopidy This web server is a part of the Mopidy music server. To learn more about Mopidy, please visit Web clients Web clients which are installed as Mopidy extensions will automatically appear here.

If I use the same mopidy.conf file and run it as root from the commandline then the webpage shows:
Mopidy This web server is a part of the Mopidy music server. To learn more about Mopidy, please visit Web clients [iris](************iris/) [mopify](******************/mopify/) Web clients which are installed as Mopidy extensions will automatically appear here.

And I get a conf file in the root home dir for /root/.config/mopidy-mopify/sync.ini

I think is has somthing with how the system service is setup

# cat /etc/systemd/system/multi-user.target.wants/mopidy.service
[Unit]
Description=Mopidy music server
After=avahi-daemon.service
After=dbus.service
After=network.target    
After=nss-lookup.target
After=pulseaudio.service
After=remote-fs.target
After=sound.target
[Service]
User=mopidy
PermissionsStartOnly=true
ExecStartPre=/bin/mkdir -p /var/cache/mopidy
ExecStartPre=/bin/chown mopidy:audio /var/cache/mopidy
ExecStart=/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf
[Install]
WantedBy=multi-user.target

As a system service it’s run as user mopidy. But thise user don’t have a home dir. And it don’t look like it can find the sync conf files used for mopidy-mopify/sync.ini
mopidy:x:123:29::/var/lib/mopidy:/usr/sbin/nologin

How should I run mopidy. I would like to not run the program as root user. But I would like the webinterface and spotyfi to work.

/etc/mopidy/mopidy.conf and same on /root/.config/mopidy.conf
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
[logging]
config_file = /etc/mopidy/logging.conf
debug_file = /var/log/mopidy/mopidy-debug.log
[http]
enabled = true
hostname = 0.0.0.0
[mpd]
hostname = 0.0.0.0
[mopify]
enabled = true
debug = true
[local]
enabled = true
media_dir = /var/lib/mopidy/media
[spotify]
enabled = true
client_id = ******************
client_secret = ********************’’’’
[spotify_tunigo]
enabled = true

Follow our documentation and install PyPI extensions as per Debian/Ubuntu — Mopidy 3.1.1-1-gf17acacf documentation

1 Like

I used https://apt.mopidy.com insted of debian. And then it worked.

Thanks:)