Timeouts when scanning files, also, nothing plays

I’m running a raspberry pi 3 with raspbian stretch, and mopidy is configured to run as a systemd service.
I’ve mounted a samba share of about 4000 files to a local directory, and it fails on about 150 of the files during the scan.

I installed mopidy through apt. the user mopidy is in the audio group.

I’ve tried setting the scan timeout to 5000ms and there’s no change. The exact same set of files fail to scan each time. I’ve tried moving the pi from wifi to giving it an ethernet link to the samba server with no change in behavior.
Does the scan just write json entries to the library file? If so, I could probably just populate that file with the missing entries of the file myself with a golang script or something that parses the output of gst-discoverrer, as gst-discoverrer has no problem parsing the id3 data from any file in my collection.

More importantly though, I seem to be missing something in the documentation because I cannot find anything on how to actually make it start playing music over the speakers I have connected to it.

Once the scan is complete, and I performed the curl -d command to update the library, I created an m3u playlist in /var/lib/mopidy/playlists from the output of find . /mnt/music -type f.

I start the service and there is no audio output, nor any indication that the daemon is doing anything. When I curl localhost:6680 I get an empty response with an exit code of 0. netstat confirms that it is listening on port 6680.

gstream sine wave test works
aplay /usr/share/sounds/alsa/* works



gst-discoverrer-1.0 output of a failed file: