Mopidy can't play local music from Samba share


I can’t get my mopidy install to play local files from a samba share. They are getting picked up fine during scan, but are not playable.

The files are on my Ubuntu server, and mopidy is running on latest raspbian install.

This is what the log file says:

2016-01-14 13:50:43,896 ERROR [1242:MainThread] Resource not found.
2016-01-14 13:50:43,898 WARNING [1242:Audio-2] Setting GStreamer state to GST_STATE_PLAYING failed
2016-01-14 13:50:43,906 WARNING [1242:Core-16] mopidy.core.tracklist: Track is not playable: local:track:VA%20-%20The%20Best%20Club%20Music%20In%20The%20Car%20%28Sound%20Clinic%20-%20Special%20Edition%29%20%282013%29/Elijah%20Collins%20-%20Two%20O%27Damn%20Clock%20%28Original%20Mix%29.mp3

So what are they ?

local or played from a network server ?

They are on A server, om my local network

Are you running Mopidy as a system service? Did you run the scan using mopidyctl (I.e. Are they both running as the same user)?

Running as system service, under root user. Runned the scan using mopidy local scan.
I’ve made sure that the permissions are fine

Have you checked that the service config file has the correct media_dir location specified? You can run mopidyctl config to print out the config the service will use.

I’ve made sure that the permissions are fine

Can I check you did this by explicitly changing to the root user and then actually accessing the files?

Is there a particular reason you have altered the system service to run as root?

media_dir i set correct, and the files are also showing in all my frontends.

I have set the permissions for all the files to 777 and also tried to chown to nobody:nogroup, with no luck :confused:
If I copy the files to the raspberry, I have no problem getting them to play.

Mainly for debugging, to see if it was something with the permissions, but also so my frontends can use auto update :slight_smile:

There should not be functional reason to run as root.

Sounds like this is really just a problem with your share security. Check your file server logs.

I can’t get it to write a log when accessing from my raspberry, but if I acces from my windows machine, I can succesfully play the music, and a log is written s:

And, if I add the folder to kodi on my raspberry, it also plays fine?

Kodi running on the same host/raspberry ?

Also, are you able to play anything at all through mopidy ?

Yea, the run on same raspberry.
Mopidy works fine using other sources; spotify, soundcloud and youtube

Does any MP3 work ?

Are you sure you have all the gstreamer packs required ?

If I save the MP3 file directly to my raspberry, mopidy plays it fine yea :confused:

And I’m pretty sure all gstreamer packs are installed :slight_smile:

I’ve made sure that the permissions are fine

Can I check you did this by explicitly changing to the root user and then actually accessing the files?

What do you mean by accessing the files?

I mean try to read them

I can read them just fine as any user :blush:

Start Mopidy the usual way (init.d or systemctl), run a ps -ef to get the whole command line.
Stop it again, and run the same command as the user mopidy usually runs with, make sure
to remove -q / --quiet and add -v -v -v, try playing a MP3.

It should run in the foreground, with max verbosity (if I remember correctly).

Got it working now! :smiley:

Made the service run as user pi, and now it works! :smiley:

10 points to anyone who can explain why this worked.