This webpage is not available when going to musicbox.local

Just bought a raspberry pi zero and why want to use musicbox. I have my network ID on the settings as “NETGEAR36” could that be part of the problem? BTW using wifi not Ethernet. Any help will be appreciated!

It could be the problem, make sure your network ssid and password are spot on.
And don’t use quotes, in settings.ini

If you can plug in a monitor and confirm your pi is connecting to the network on boot up

Are you able to ssh in to your pi?

But can you get to the web page using the IP address? Because what happens when you type into your browser that address is that is translated to an ip by a Domain Name System server. Now, if something is wrong with the settings, it is possible that even though the web page is sent by the pimusicbox, the address is simply not translated correctly. This can also occur if you change the host name of the pi to something other than the default “musicbox”. If you change it to, say, “mymusicbox”, the the correspoding address for the web page will be mymusicbox.local

Find out the ip. One way to do this is to go to your router and look up the ip that the pi is getting. Then type that address into a browser.

@tot_rispekt dope man! thanks for the tip - just worked for me!

Reviving post but I got the same issue. I can find the IP address but http://musicbox.local is not working. Any ideas, please?
The thing is that the IP of the RPi may change so I have to try and find it everytime (plus cannot bookmark it so as to find it easily).

Are you using a pc or phone?
As a workaround could you set a static IP using the MAC address on the router.

Both from phones and PCs!

I would do that but my router (USR 9108) does not support that…

Interesting thing is that both in the router and in the windows network my RPi is recognized as MusicBox

So, how about just http://musicbox on your PC? If the router knows the hostname, it should be telling your PC via dns

Same “server not found” :frowning:

Are you using Edge browser - I can’t go to musicbox.local on Edge (but can use the IP address) but can go to musicbox.local on Firefox or Chrome.

Actually I just now realized I’ve been using musicbox/local instead of musicbox.local… Thanks a milliong for the help!

So it works in the computers but still not in Android Chrome.


.local doesn’t work in android. You’d use just musicbox. To be really clear, that’s: http://musicbox/

Im having the same issue, it been working for ages now and today forsome reason i cant get anything from musicbox.local, ive tried just musicbox as well.

i can still airplay tho, just cant get the webclient to load. any ideas?

I replaced my setting file with the one from github and made the changes and now it works.