Subsonic settings breaks web interface

This is my first attempt at setting this up I am looking for a solution to the problem I am having.

first my environment is a windows AD domain system and subsonic is not integrated with AD. So I set the workgroup to my domain name. The first time i tried this i saw it list my domain controller IP addresses but have not seen this since that time.

when I attempt to set up subsonic I run in to a couple of issues first I have my own subsonic server set up with an SSL cert so have a website as per if I attempt to use this and set ssl to yes the system complains about a port number being required so I tried to use 443 with no luck.

when I attempt to use the direct server name address as per in a navigation bar servername:port#
I enter the servername in the hostname field and the port number in the port # I do not get any errors pertaining to subsonic only the ones for webinterface and

If I disable subsonic I get no errors and am able to get to the web interface.

Does anyone have any clues as to where I am going wrong here?

Can’t help you with the SSL issue, but I found that adding a playlist in Subsonic solved the problem with the webUI not loading when Subsonic was activated.

I worked this out by checking /var/log/mopidy/mopidy.log - it was reporting an uncaught exception with a method that was checking for a playlist in Subsonic. Basically, if there isn’t a playlist in Subsonic, the mopidy-subsonic back-end extension crashes.

Probably easily fixed by anyone who knows more about this kind of thing than I do, but even if you don’t, it would be worth checking to see if you’re seeing the same thing in your log.

If you can - try adding a playlist in Subsonic (any playlist, even if it’s just one track) and reboot PiMusicbox. That did the trick for me.