Network config in pimusicbox

Just booted pimusicbox 0.6 w/wired ethernet. After a couple minutes it does show up at http://musicbox.local. However it’s IP address is Why didn’t it use dhcp to get a normal address on my lan? I reburned the img making only two changes in settings.ini to enable ssh and set a password. Same result. I suspect if I was using wifi it would get an address but there is something wrong with the default wired config.


After futzing around for a while I did get it to work. I think it was adding “netmask” to the interfaces file that did it, but I’m not sure. Very strange. My router was getting the DHCPDISCOVER requests, but was not responding I guess. Then suddenly it started to work. I added the netmask setting because the DHCPDISCOVER log entries were saying and that looked wrong, but even after adding this setting those log lines didn’t change. However it does get a dhcp response and work now.

New problem: my subsonic url is rooted at /subsonic/ and not /. It looks like the config entries don’t allow for that. Any suggestions?


Thanks for updating with the fix, I’ll add a note about that.

Regarding subsonic, doesnt the ‘context’ setting allow for this?

I’m not sure where this context thing is, but looking at the code this is supported in libsonic as an optional argument to the Connection initializer, but mopidy_subsonic doesn’t send that argument (serverPath). So I don’t think it’s possible. I could switch from a reverse proxy to a virtualhost so I wouldn’t be changing the base url. Bit of a nuisance to change all my clients though (5 family members). So, just for grins I editted mopidy_subsonic to pass “serverPath=’/subsonic/rest’”. I don’t get an error on startup now, but I can’t seem to find subsonic in the web UI. Where should it show up? I thought I’d see subsonic under browse but I don’t.


I was referring to but unfortunately there hasn’t been a release since it was added (February).

I don’t think it supports browsing, only playlists and searches.

Ok, thanks for your help!