Can't get the Pi MusicBox web interface to run no matter what I try

I’m hoping someone can help me with this.

I’ve been running Pi Musicbox for a short time. What I want to use it for is to use the web interface to listen to podcasts and radio station streams, and use librespot to as a Spotify Connect client.

It works as well as I think it can as the Spotify Connect client. But despite googling it exhaustively, trying all the solutions I’ve found, I still can’t get the web interface up.

Port 80 is not open, and nothing is listening on it, despite the fact I have the web interface enabled. I have configured it to use “musicbox” and “musicbox-webclient.” neither do anything.

I have pored over logs and see no mention of an attempt to start the web interface, nor any errors other than CryptographyDeprecationWarning in the Mopidy log (“OpenSSL 1.0.1 is no longer supported by the OpenSSL project, please upgrade”). Also, I don’t know all of the signs to look for.

here’s what I think are the pertinent contents (and thensome, probably) of my settings.ini file. Please let me know if I should post any other outputs.

workgroup = WORKGROUP
enable_ssh = true
enable_firewall = false
wait_for_network = true

enabled = true
username = xxx
password = xxx
client_id = xxx
client_secret = xxx
bitrate = 320
cache_dir = "/var/cache"

enabled = false
client_id = 
client_secret = 
enabled = false
username = 
password = 

enabled = false
auth_token = 

enabled = false
username  = 
password = 
deviceid = 

enabled = true

enabled = true
api_key = 473279e3fa0e7010cbbbb40ecc31890d46e57a2e
countries = US, NL, DE, NO, SE

enabled = true

enabled = false

enabled = false
encoding = mp3
quality = fast

enabled = true

enabled = false

enabled = false
username = 
password = 
quality = HIGH

root_password = 
resize_once = false
scan_always = false
autoplay = 
autoplaymaxwait = 60
webclient = musicbox_webclient
enable_mpd_watchdog = true
enable_shairport = 
enable_upnp = 
enable_connect = true
downsample_usb = true
output = analog

mixer_volume = 90
output = alsasink
mixer = software

enabled = false
card = 1
control = Master

enabled = true
hostname =
zeroconf = ""
static_dir = /opt/musicbox/webclient

enabled = true
musicbox = true
websocket_host = 
websocket_port =
on_track_click = PLAY_ALL

musicbox = true
config_file = /boot/config/settings.ini

hostname =
zeroconf = ""

cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy

config_file = /etc/mopidy/logging.conf
debug_file = /var/log/mopidy/mopidy-debug.log

Any help would be very appreciated, thank you.

There is an iptables rule to redirect port 80 to port 6680 where Mopidy should be listening. Maybe there is something in the startup log that’s present in /var/log/?