Mopidy (w/Musicbox) + Subsonic Failing

I’m setting up a multi-RPi system (whole house audio-1 RPi/room), and I started with a B for test, but now B+'s are more available and cheaper. So I’m transitioning to the B+ with my test RPi. I had this mostly working with the B for use primarily with a Subsonic server (some intermittent issues with play when initiating from different devices via Musicbox’s web interface). I’ve updated to Musicbox 0.5.3 (Mopidy 0.19.5) and Subsonic 5.1. This (mostly) works with the B, but not the B+. I can start Tunein with no problem. And when I choose Playlists, I get the list from the Subsonic server. But when I choose a song, the playback never happens.

I’ve run mopidy manually from ssh and gotten the following:

WARNING  Found subsonic configuration errors, the extension has been automatically disabled:
WARNING    subsonic/username must be set.
WARNING    subsonic/hostname must be set.
WARNING    subsonic/ssl must be set.
WARNING    subsonic/password must be set.
WARNING    subsonic/port must be set.

But my settings.ini is the same as what was working in the B (the same micro-SD card):

# ------------
# | Subsonic |
# ------------
# Edit these lines for Subsonic support
# Set the hostname = (leave off http/https)
# Enable the service or not (true or false)
# Set to true to enable Subsonic
enabled = true
hostname =
# Set the port. e.g. port = 8888
port = 4040
username = username
password = password
# SSL yes or no
ssl = no

Why is this failing?

Note that I’ve tried removing the spaces and surrounding the entries with double-quotes, but gotten the same results.

Config looks sane to me, but are you sure you are using the same config file when running it manually?

I’m not sure, since I don’t know how to do otherwise. That might make some sense, though. Should I even be able to see the playlists if the Subsonic extension is disabled?

So how do I get the log for Mopidy when it’s auto-launched?

I think musicbox has it somewhere in /var/log/... but I’ve yet to use musicbox myself, so not 100% sure.

The log is in /var/log/mopidy/mopidy.log as normal but the default in
musicbox is to only log warning (and above) messages.

Thanks for the info.

I moved the SD card back to the B, but to my surprise, the behavior is the same (can get play lists but not play songs).

I checked the mopidy log, but there are no errors.

There is something fundamental wrong, but it’ll obviously take some in-depth debugging to find.

I’m a professional programmer in several languages and environments, but I have zero experience with Python. I read some info on the language, which seems straightforward enough, but I can’t make out where the entry point in mopidy and these plugins would be. I’m also not sure when changes I’d make would be activated (reboot required? Restart mopidy? How, since above we determined that ssh launch doesn’t use config.)

This wasn’t something I really planned to have time to pursue. So any guidance that could shorten the process would be greatly appreciated.

Use the --config option and specify the config file to use. The service will use a different config file compared to running it in the terminal as per

Try running it from the terminal (specifying the config as above) and with more verbose output.