[Solved] Cannot access Mopidy


Please help, I’m a beginner as for raspberry and linux.
I could install mopidy, set the confog file, but cannot access mopidy.
I’ve read a lot of topics but still not working.

I used in config:

enabled = true
hostname = ::
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

If I start the browser on pi , I have access with “raspberrypi:6680” address

but from my laptop not.
Shall i typie also into the browser in my laptop "raspberrypi:6680"
I tried with the ip of pi not works.

Mopidy startup:

INFO Starting Mopidy 2.1.0
INFO Loading config from builtin defaults
INFO Loading config from /home/pi/.config/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: http, stream, m3u, softwaremixer, file, party, local
INFO Disabled extensions: mpd
INFO Starting Mopidy mixer: SoftwareMixer
INFO Starting Mopidy audio
INFO Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
INFO Audio output set to "autoaudiosink"
INFO Loaded 23 local tracks using json
INFO Starting Mopidy core
INFO Starting Mopidy frontends: HttpFrontend
INFO HTTP server running at [::]:6680
INFO Starting GLib mainloop

Thank you for your help in advance!!!

Best regards,

You want the actual ip address, have a look on your router maybe for the ip address.
Mine is
Which webclient have you installed
You could try raspberrypi.local from your laptop
You are running as a user not as a service aren’t you?

I’ve installed Party web client, yes I’m running it as a user.
What should i do with my router?
Sorry but what does it means raspberry.local?
Sorry! I’am a really beginner in this topic

Can you access your router from your web browser, and find the ip address it’s given to your raspberry pi it will be something like 192.168.0.?

Alternatively from the command line type ifconfig (Link here)

Thank you it works. I checked you wrote, it gives the address to raspberry.
And if I put this ip to browser , it works :slight_smile:
I would have an other question. How could I fix the ip for raspberry. I assume this ip what router gives to raspberry may change (reboot, power loss)
Is it possible to add a name instead of an ip address (as an alias)

I set mine on the router - it’s easier than setting a static ip address on the pi. Have a look for the DHCP settings on the router, the option to ‘reserve an i.p.address’ is usually in there.

To set it on the pi have a look here

To access with name try in the browser http://nameofpi.local:6680
Substitute nameofpi with name of your own machine

Great, Thank you again!!!
nameofpi.local:6680 works well . In this case I do not need a static ip? Do I?

Probably not, however I don’t think Android (for a phone) will connect using the name.local and will need the i.p. address so I stick to using the i.p. address. This could be outdated now - I’ve had my setup for a while and things may have changed.

I believe you are right @Steve_Lambert. Android still doesn’t support that properly.

Depending on your router, http://nameofpi:6680 may just work. Else an address reservation is the way to go.

1 Like

Thank you for the answers, I would have a new one :grinning:
I installed three frontend : party, simple-webclient, jukepi
All three accessible if I run mopidy from command line, but if I started mopidy as a service, only party is visible.
I coped the config file from home/pi/.config to /etc/mopidy/.

Any idead?
Thank you in advance!

They must be installed with sudo pip install mopidy-whatever.

Thanx again. It works.
Are you familiar with jukepi client?
If I select this first, I cannot see any files what are stored locally, but if I load a playlist with other (e.g mopidy-simple-weblcient), and go back to jukepi, jukepi will see the files.

Sorry, not familiar with that client.