MOPIDY not working after install


I’m trying to get Mopidy working on a headless Raspberry Pi B.
Installed Jessie-lite OS, done upgrade, installed Mopidy by following the docs.
I’m connecting to my pi over ssh.
When launching mopidy this is the readout :

INFO Starting Mopidy 2.1.0
INFO Loading config from builtin defaults
INFO Loading config from /home/pi/.config/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: mpd, http, stream, m3u, softwaremixer, file
INFO Disabled extensions: local
WARNING Found local configuration errors, the extension has been automatically disabled:
WARNING local/media_dir must be set.
WARNING Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO Starting Mopidy mixer: SoftwareMixer
INFO Starting Mopidy audio
INFO Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend
INFO Audio output set to "autoaudiosink"
INFO Starting Mopidy core
INFO Starting Mopidy frontends: MpdFrontend, HttpFrontend
INFO MPD server running at [::ffff:]:6600
INFO Starting GLib mainloop
INFO HTTP server running at [::ffff:]:6680

This time I changed to hostname = (which is the IP-nr of the PI) but I get the same results when I put hostname = :: in the mopidy.conf

In all case I don’t get the webserver up. I’m scanning all ports but nothing on 6600 and 6680

What am I doing wrong?? Do I need to resolve the warnings before the webserver gets up? How then?


Hi again,

since nobody seems to come up with a solution and also since I have re-imaged my sd-card, tried different sd-cards, tried PiMusicbox v0.7 and just now Pimusicbox v0.6 and since none of them are able to start ssh nor http and since I tried on a different Raspberry Pi 1 B

I start to think it just doesn’t work on Pi1 ?

Should I Buy a PI3 ? Or am I (again) overlooking the obvious?


In your mopidy setup, have you tried hostname =

Are you using wifi dongle or cable on the Pi to connect. Some wifi dongles appear to cause connection problems.

I think it will operate on all versions of the Pi.

Have you enabled SSH in the config settings.

Hi Steve,

Thx for the support.
I have indeed set enable_ssh = true in the settings.ini file

hostname, both under [html] and [mpd] are set to by default so that should be ok.

The PI is for the moment wired directly to my router and receives an IP-address. No problem to ping it!
I’m using a network scanner to check for listening ports but both ssh and html don’t come up!


I think there’s sone confusion here. Enable_ssh is a pimusicbox config setting that belongs in /boot/config/settings.ini. Pimusicbox is an sd card image with a bunch of extra scripts to make configuration easier. You have described installing mopidy manually on jessie lite so you are not running pimusicbox so you don’t have an enable_ssh config setting. You also won’t have a settings.ini file and there’s no [html] section in either setup.

I apologise, it seems you did also then install pimusicbox.

All versions of pimusicbox and normal mopidy run on a raspberry pi B. Pimusicbox should work out of the box, it might take a few minutes to come up for the first time. Normal mopidy will require you to set the http/hostname setting to allow connections from other machines.

Have you tried just connecting in your web browser?

Hi Kingosticks,

Thx for the support. I do apologies for the confusion. I actually started of with PiMusicbox but couldn’t get it to work(no html, no ssh). Therefore I started from a fresh Jessie and installed Mopidy but with no html. (My first message was about the Mopidy install) I went trough two or three sd-cards and two Pi’s but no luck. Then I decided to use an image PiMusicbox v0.6, which is at the moment on my Pi but again no ssh nor html.
I’ve waited for hours since I thought that maybe it takes a lot of time but…sorry no changes!

I will revert to a fresh Jessie image and install mopidy because at least than I succeed in ssh-ing into my headless Pi. Soon as I have done that I will come back to the forum!


That’s no problem. If you are still having problems with your fresh jessie based install, please post the output of sudo mopidyctl config and make sure the service is running with sudo service mopidy status (I am assuming you are aiming to run mopidy as a service).

Hi All,

Guess what? Got Musicbox v0.7 working…html and ssh!!!
Decided to buy myself a new sd-card and that did the job!

When I have a spare moment I will try the other sd-cards again since I saw that with the new one it took a while before all services(ssh & html) came up. I’m quiet sure I have waited before but I could be mistaken!

Anyway It works! Let the music playon!

BTW: I have had so many problems with the instability of sd-cards in the past that I normally use USB-sticks to run the OS from (sd-card is only there to redirect boot to the USB) Since I’m working that way I have never/ever had any issues. I’m under the impression that Musicbox doesn’t work when run from a USB-stick. Will definitely try later and come back to the forum with my findings later!

Glad you got it sorted - it does pay to get a decent card, I’ve wasted a few by buying the cheapest ones.