Can't access Mopidy through localhost

Hi all,

so I just installed Mopidy on my Raspberry Pi 2 using the instructions in the documentation. It boots fine and gives me the “HTTP server running at [::ffff:127.0.0.1]:6680”.

I also installed Mopidy-Moped and that seemingly installed fine.

In the Mopidy config I have

[http]
enabled = true
hostname = 127.0.0.1
port = 6680
static_dir =
zero_conf = Mopidy HTTP server on $hostname

and yet I can’t access http://localhost:6680/moped using Firefox on my Windows 7 desktop. I just gives me an page loading error.

I can access 127.0.0.1 which gives me the generic IIS7 Welcome screen but I can’t access 127.0.0.1:6680.

So what am I doing wrong?

Thanks in advance.

confused_hedgehog

From the warning at https://docs.mopidy.com/en/latest/ext/http/

As a simple security measure, the web server is by default only available from localhost. To make it available from other computers, change the http/hostname config value.

You need to set the http/hostname config setting to either 0.0.0.0 or :: to allow connections from other computers. Then you need to use the IP address/hostname of your Raspberry Pi in Firefox.

I just tried both of those and it doesn’t work. Firefox still gives me the same error.

I can SSH into my Pi just fine using Putty so I know I have the IP right at least.

Also even though I changed the #hostname value when I start Mopidy it still says “HTTP server running at [::ffff:127.0.0.1]:6680”

The config key is “hostname”, not “#hostname”. The “#” in the start of the line marks a comment, making your config file change have no effect.

Damn it I knew it would be something super simple and dumb on my part. Thanks.