Setting media_dir for mopidy local to external usb drive

Hi all,

I installed mopidy and would like to use mopidy local as a service. I mounted my external usb stick (with music on it) on /externalsd/ and find the files in linux. in the mopidy config file (both service and non-service) I set media_dir = /externalsd. However:

pi@raspberrypi / $ mopidy local scan
INFO     Starting Mopidy 1.0.7
INFO     Loading config from builtin defaults
INFO     Loading config from /home/pi/.config/mopidy/mopidy.conf
INFO     Loading config from command line options
INFO     Enabled extensions: mpd, softwaremixer, http, m3u, stream
INFO     Disabled extensions: local
WARNING  Found local configuration errors, the extension has been automatically disabled:
WARNING    local/media_dir must be set.
WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
ERROR    Unable to run command provided by disabled extension local

Appearantly my settings are not set yet. Searching around I learned there are some file permissions to be set for the user “mopidy”. I tried some but no success so far. Does anyone have any pointers for me?

Thank you in advance :slight_smile:

Have a look at

Thanks, one step closer! The solution was mopidyctl local scan, I get it now.

pi@raspberrypi /var/lib/mopidy/local $ ls

the library has been made. however, in my MPD client I do not see anything yet?


EDIT: Remarkably the MPD client on my android phone sees the library, so all is fine. The client on my Windows PC, however, does not…