Can't get Mopidy Local working

Running mopidy on a headless raspberry pi, it’s basically working, I can play music but (see other posting recently) I’m digging around trying to work out how to play albums in track order.

So I am trying to get Mopidy-Local to help, but it just returns errors, as follows:-

root@homepi:/usr/share/mopidy/conf.d# mopidy local scan
INFO     2023-12-18 17:29:21,617 [38815:MainThread] mopidy.__main__
  Starting Mopidy 3.4.1
INFO     2023-12-18 17:29:21,672 [38815:MainThread] mopidy.config
  Loading config from builtin defaults
INFO     2023-12-18 17:29:21,675 [38815:MainThread] mopidy.config
  Loading config from file:///root/.config/mopidy/mopidy.conf
INFO     2023-12-18 17:29:21,676 [38815:MainThread] mopidy.config
  Loading config from command line options
INFO     2023-12-18 17:29:21,919 [38815:MainThread] mopidy.__main__
  Enabled extensions: mpd, m3u, stream, softwaremixer, file, http
INFO     2023-12-18 17:29:21,920 [38815:MainThread] mopidy.__main__
  Disabled extensions: local
WARNING  2023-12-18 17:29:21,920 [38815:MainThread] mopidy.__main__
  Found local configuration errors. The extension has been automatically disabled:
WARNING  2023-12-18 17:29:21,920 [38815:MainThread] mopidy.__main__
    local/media_dir must be set.
WARNING  2023-12-18 17:29:21,920 [38815:MainThread] mopidy.__main__
  Please fix the extension configuration errors or disable the extensions to silence these messages.
ERROR    2023-12-18 17:29:21,920 [38815:MainThread] mopidy.__main__
  Unable to run command provided by disabled extension local

My config file is:-

[http]
hostname = 0.0.0.0

[mpd]
hostname = ::

[file]
enable = false

[local]
enable = true
media_dir = /var/lib/mopidy/media

There most definitely are files in /var/lib/mopidy/media, it’s where Mopidy is playing them from already. … and what does it mean “local/media_dir must be set.”, it is set and contains my music library.

Are you running Mopidy as a service or a user (root??!?!). Please specify which config file you edited and what command you used to run the local scan.

https://docs.mopidy.com/en/latest/running/

Ah, sorry. I’m running mopidy as a service and thus the config file
is /etc/mopidy/mopidy.conf.

I ran ‘mopidy local scan’ as root. I tried it both with mopidy running
and with mopidy stopped by systemd.

The docs link I provided explains the situation, please take a look.

sudo mopidyctl local scan