Mopidy Discourse

Raspberry Pi 4, hifiberry on Ubuntu 21.10

Hi!

Has anyone attempted the combination of Rpi 4, a Hifiberry DAC Plus/HD running on Ubuntu 21.10?

I just ran a fresh install to a new SSD today and have most of my plugins and packages setup and running. Iris is able to read my local library

Problem is my audio DAC hat isn’t showing up. I’ve tried adding the overlay to config.txt and scanning with aplay -l to no avail. i2c is enabled in config.txt as well.

all suggestions welcomed! thanks

my hunch is this is a kernel bug in 21.10.

5.13.0-1009-raspi #10-Ubuntu SMP PREEMPT Mon Oct 25 13:58:43 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

Have you tried the same hardware with Raspberry Pi OS?

no, but I have used it successfully with Ubuntu 21.04.

I was sticking with Ubuntu because they have a real 64bit kernel. RaspberryPi OS’ 64bit version is still in beta, though apparently Ubuntu isn’t exactly well tested with different hardware. So it may be worth trying.

Thanks for the suggestion!

Personally I’d favour the OS that works best with all hardware rather than 64-bit support. Ubuntu will technically be faster because they compile their software with all the extra performance optimisations enabled (because they don’t support the earlier Pi versions), but if you are after that level of extra performance you are wasting your time with a Pi.

This is for an older version of Ubuntu but it may still hold true. You are probably better off asking on the hifiberry forums anyway: https://support.hifiberry.com/hc/en-us/community/posts/360013945658-Hifiberry-DAC-and-Ubuntu-20-10

hey @kingosticks,

I’m using this as a kind of general purpose audio and video playback device, so was hoping to eke out a bit more from it. I guess I could downgrade to 21.04 which was working for me.

I had seen that post you referenced already but it didn’t help my case. I’ll keep poking at it, thanks!