R Pi2 B + HifiBerry DAC Plus = Frustrated

Hi All

I am trying to setup the Pi MusicBox, but I am having a world of trouble.

When I boot the RPi I am left with the following error messages:
INFO Disabled extensions: gmusic, youtube,…,soundcloud
WARNING Found music_box webclient configuration errors, the extension has been automatically disabled:
WARNING musicbox_webclient/musicbox unkown config key.
<codeWARNING Please fix the extension configuration errors or disable the extensions to silence these messages.
ERROR Unable to run command provided by disabled extension local

I can however access the web interface via an android tablet.

I have been unsuccessful in determining what the issue is. I was hoping someone would be able to take a look at the audio settings for me and hopefully point me in the right direction.

An extract of the settings file:

# ------------------
# | Audio Settings |
# ------------------
# Because of limitations with some USB-DACs, MusicBox downsamples USB sound to 44k by default. Set to false to disable.
downsample_usb = true

# Set default audio output. This overrides the automatic detection (which sets to usb audio if an usb audio device
# is found, else to hdmi (if hdmi is connected at boot), and otherwise just to the analog out).
# i2s cards (e.g. HifiBerry etc) are not detected automatically and must be explicitly set here.
# Options: analog, hdmi, usb, hifiberry_dac, hifiberry_digi, hifiberry_dacplus, hifiberry_amp, iqaudio_dac
output = hifiberry_dacplus

# Set the startup volume of MusicBox
# Values: from 0 to 100
mixer_volume = 85

# --------------------------------------------------------------------------
# | OTHER Settings |
# | You probably don’t want to edit the settings below this line. Really. |
# | Unless you know what you’re doing, or you want to change the webclient |
# --------------------------------------------------------------------------
# This sets the gstreamer buffer. It’s a bit tricky…
# If you have problems with stuttering sound, try other values here, like:
# or
#output = alsasink buffer-time=300000 latency-time=20000
#output = alsasink buffer-time=200000 latency-time=10000
output = alsasink

mixer = software

# Optionally, you can use alsamixer. This enables you to use hardware mixers of usb/audiocards.
# Set the previous setting to:
#mixer = alsamixer
# And set the card and contol below. E.g.
#card = 1
#control = Master
# Run the command ‘amixer scontrols’ from the commandline to list available controls on your system
# See https://github.com/mopidy/mopidy-alsamixer
card = 1
control = DSP Program

enabled = true

enabled = true
hostname =
port = 6680
#Disable zeroconf
zeroconf = “”

I would really appreciate any assistance in getting this to work.

Thank you.

What actually is your problem here?

Assuming it’s that you cannot play any local files then please provide the full startup log as it should explain why local was disabled. Also please provide your entire settings.ini file (with sensitive info removed) as the part you provided has nothing about [local] or your network-mounts (if using).

Or, if it’s that you don’t hear any audio then please provide the output of aplay -l and check the contents of /var/log/syslog for any system startup errors.

If you could also use something like http://dpaste.com that would be great.