Raspberry Pi 2 with Hifiberry Amp + (tried with Musicbox 0.6RC)

Hi there!
As you see in topic, I combined my Raspi 2 with the Hifiberry Amp+. To install Musicbox, I first tried the official version 0.5.3 - but it doen’t start at all, the screen keeps colored.
So I installed the Release Candidate of 0.6. And almost everything works fine, if I use the internal soundcard of the Pi. But the HifiBerry Card seems to be not recognized. There comed no Sound out of it, and if I type “aplay -l”, only the “bcm2835” apperas as card0.
Does anyone have an idea, what I could try? Or should I hope for the next version?
Thanks a lot!

Can I first check that you did specify output = hifiberry_amp in the correct place in settings.ini ?

If so, could you provide the output of running ./opt/musicbox/setsound.sh and lsmod.

1 Like

If you are still having problems I think the answer is to add snd_soc_tas5713 to the file /etc/modules. I don’t have this audio card so it’s impossible for me to test it. Can you please try that and report back so I can fix the image? Thanks.

1 Like

You have to enable the Amp in the config.txt and activate the Alsamixer

Hifiberry.com Support
Edit the Alsamixer

Musicbox doesn’t use device overlays. It uses the previous kernel method of
loading modules. If amp support is to be included it needs to use loadable

Ok, learned something new :wink:

Can you add hifiberry_amp and alsamixer to mopidy-websettings/mopidy_websettings/index.html or is it not possible to set the right parameters for the alsamixer via the webfrontend?

Hmm I’m not sure if websettings supports setting the alsamixer settings.
Might need to update it and add that. Otherwise you’ll have to just add it
manually to settings.ini which isn’t ideal.

My problem is only the reset to audio_mixer = software after the usage of the “settings” Webpage.

To solve the Problem for me, i added some code to
/usr/local/lib/python2.7/dist-packages/mopidy_websettings/index.html - line 145

            <option value="hifiberry_amp"{% if musicbox__output == "hifiberry_amp" %} selected="true"{% endif
%}>HifiBerry Amp(+)</option>

and changed

audio_mixer = autoaudiomixer


audio_mixer = alsamixer

I did that hack because i’m unable to change the slider to a menue to change between “software”, “autoaudiomixer for USB” und “alsamixer for Hifiberry Amp”.

If you could submit an issue to the websettings github page we can get it
fixed for next release.

Sorry, that my answer comes so late. I tried the first two hints and now everything works fine. Thank you a lot!

I’d appreciate if you could clarify exactly what made it work. As I don’t
have that card I’ve no way of checking, thanks.

Ok, of course. The crucial point was the line “output = hifiberry_amp” in the settings.ini.

BTW: Another question:
The output volume is very high for my usage. More then 20% are not tolerable with the loudspeakers I use. So it is hardly possilble to adjust the volume to a spezial value using the slider in the web frontend.
Is there a way to limit the maximum volume? An to define, that pulling the slider to maximum adjusts the volume to 20%?

You probably need to enable hardware mixing. Are you set on mixer=software

Just to Let you know, setting output = hifiberry_amp worked for me too on a pi b+ win hifiberry_amp.
If it could be an option in the drop down menu, it should work out of the box.