PiMusicBox with Hifiberry DAC+

Hello Folks,

I am very new to the raspberry pi and all that stuff.

Here is my ‘project’:
I want to have a music streamer. So I decided to go with a raspberry pi and the musicbox.
I have a ‘Raspberry PI 2 Model B’ and bought myself a ‘HiFiBerry DAC+’ to get a decent sound out of it.
Once the hifiberry was on the raspberry i put in a sd-card with a pi-musicbox image (the latest 0.6.0 build).

Here is my problem:
I dont get the settings correct so the webinterface works and the hifiberry is working.

I already searched the web, but all the suggestions did not work for me.
Everytime I get the message, that there is an invalid key in the configuration and the extension gets disabled.
I also tried to put in an image with no editing in the config files and just did it in the webinterface whilst running.
But it resulted in the same error.
I already read and tried: settings-for-pimusicbox-0-6-and-hifiberry-dac

Is there a known working configuration or is it just me who is not clever enough?

Kind regards,
alex

Hi, as I said in the reply to the post you linked:

Number one, that should not be necessary. That card should follow the exact same procedure as the others I.e put output = hifiberry_dacplus in settings.ini. If any other steps are required then that is a bug.

The steps described in that post are not how musicbox v0.6 is designed to work. I suggest you restore /boot/config.txt to exactly how it was and set output = hifiberry_dacplus in /boot/config/settings.ini. Then if you can post the exact error message you get we can go from there.

If the output works, but is distorted or too loud then please follow the good advice at Settings for piMusicBox 0.6 and HifiBerry Dac +?

Thanks for you fast reply.

I will do the following at home:

  • format sd-card and put a new image onto the sd-card
  • edit the one line and then see what it will do

Do you know a method to get the whole startup log?
Or do i have to do the typing from screen?

Another question:
Are you the/ one of the developer of the musicbox?

It might be in one of the other log files in /var/log, I’m afraid it’s been a while since i had 0.6 running and I can’t remember exactly. If you log in via ssh you can copy and paste directly from these files.

I am currently the maintainer of musicbox.

Sorry to say, but the easy way of changing just the on value did nothing…
This is how my settings.ini looks like:

enable_ssh = true
output = hifiberry_dacplus
# OTHER Settings
output = alsasink
mixer = software
[alsamixer]
card =
control =

This is the content of the /var/log:
apt boot.0 boot.2.gz boot.4.gz dmesg.0 dmesg.2.gz dmesg.4.gz lastlog mopidy watchdog
boot boot.1.gz boot.3.gz dmesg dmesg.1.gz dmesg.3.gz fsck monit.log samba

The error messages looks like this:
WARNING Found alsamixer configuration errors, the extension has been automatically disabled:
WARNING alsamixer/control must be set.
WARNING alsamixer/card must be set.
WARNING Found musicbox_webclient configuration errors, the extension has been automatically disabled:
WARNING musicbox_webclient/musicbox unknown config key.
WARNING Please fix the extension configuration errors or disable the extension to silence these messages.

Those are warnings, not errors; musicbox should function just fine with those as they are. But you can silence the alsamixer one if you like by changing the relevant part of settings.ini to the following:

[alsamixer]
enabled = false
card = 
control =

Is your hifiberry still doesn’t work then please post the output of aplay -l and cat /etc/asound.conf.