Python error when starting Mopidy on Raspberry Pi

Whenever I try to start running mopidy on my raspberry pi, I get the following error:

ERROR: Mopidy requires Python 2.7, but found 3.2.3.

Yet when I run python --version I get the following result Python 2.7.3

What’s going on here?

I’m guessing that you used pip to install Mopidy? And that pip use Python 3, thus it installed Mopidy into your Python 3’s site-packages directory.

If you run pip --version, it will show you what Python version that pip executable belongs to. For example:

$ pip --version                                                          
pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7)

If this says anything else than “(python 2.7)” you should uninstall Mopidy:

pip uninstall mopidy

And then reinstall using the pip executable matching your python2.7 installation, or using some alternative installation method, like apt-get. Often, you’ll have pip2 and pip3 commands which install’s into your python2's and python3's site-packages, respectively.

Thank you very much, I stupidly installed something with pip-3.2.

Thank you again for clearing that up!