I read through this older post - Python error when starting Mopidy on Raspberry Pi
It refers to ensuring that one use the correct version of pip (one that uses Python 2.7). I’m not sure this is relevant based on the current state of Mopidy in that the installation process does not use pip currently.
I flashed a new environment on my RPi3B for my AIY Voice Kit. It is running Linux raspberrypi 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux
I went through the Mopidy installation procedure outlined here - https://docs.mopidy.com/en/latest/installation/debian/#debian-install
I am now attempting to create and edit the mopidy.conf file. When I invoke mopidy in the terminal window, I get the error message about Mopidy requiring Python 2.7.
“Mopidy requires Python 2.7, but found 3.2.4”
I checked the image and Python 2.7 is present.
I am relatively inexperienced with Linux, but it occured to me to try to create a virtual environment in my home directory (/home/pi) (virtualenv -p /usr/bin/python2.7 mopidy/env) to see if Mopidy would then “see” Python 2.7. After activating the environment, I tried running ‘mopidy config’ again. Alas, this did not solve the issue.
To prepare for installing Mopidy on the AIY Voice Kit, I recently went through a complete installation of the most current version of Raspian. I flashed Raspian Stretch. I installed and configured Mopidy, Mopidy-Spotify, and Mopidy-TuneIn. Throughout this process, logged in as user ‘pi’, I did not encounter this issue.
Today I flashed the AIY Voice Kit image on an SD card. I have that image up and running and I am logged in as ‘pi’. Following the Mopidy installation process exactly as I did with the “vanilla” Raspbian, gave this Python version error from Mopidy. This environment’s Raspian software must be deployed slightly differently that a “vanilla” Raspian installation, obviously.
How do I get Mopidy to see Python 2.7?