Raspbian wheezy package: wrong Python version package required


Today, after running apt-get upgrade, I got the following error message:

The following packages have been kept back:

After attempting to re-install it, I got the following:

The following packages have unmet dependencies:
   mopidy : Depends: python:any (< 2.8) but it is not installable
            Depends: python:any (>= 2.7.5-5~) but it is not installable

Looking at http://archive.raspbian.org/raspbian/pool/main/p/python2.7/, I noticed that Raspbian wheezy is stuck at python 2.7.3 (which is the case on my pi).

Is there a way to get that fixed? (If not, I’ll have to update my pi sooner than I previously anticipated).


The wheezy instructions at https://docs.mopidy.com/en/latest/installation/debian/ should fix it.

1 Like