Netgear N300 unable to connect to wifi

I decided to finally go far with MusicBox. So I went out and got a Netgear N300 wireless adapter. I have a Linksys EA6400 wireless router, SSID: Alt-Stowers and the security is set to WPA2/WPA Mixed Personal (I tried WPA2 Personal as well).

I plopped in the password and when I boot it up, it says “Waiting for network…” about 7 times then finally says “[ ok] IP address is . Connect to MusicBox at…” I have no idea what that IP address is. It isn’t local or external on my network.

I have used both a powered USB hub and directly connecting to the pi. (I have a RPI B model.) When I unplug the adapter and plug it in it gives the product, manufcaturer, usb id all that good stuff… then it says:

snd-hifiberry-digi snd-hifiberry-digi.0: ASoC: CODEC wm8804.1-003b not registered
snd-hifiberry-digi snd-hifiberry-digi.0 snd_soc_register_card() failed: -517
platform snd-hifiberry-digi.0: Driver snd-hifiberry-digi requests probe deferral

Can’t seem to get this USB wireless stick to work… eth0 works fine\

Any help would be appreciated.

The ip you get means it was unable to connect to a dhcp server, so it is possible that dhcp is off on your router.

You can also connect a screen and a keyboard to the pi to configure the wlan adapter via the command line using this guide

DHCP is on in the router settings.When I run an ifconfig, wlan0 doesnt show up. It does appear in lsusb. When I scan for wireless access points it says interface doesn’t support scanning.

Not sure where to go from here.

Edit: I tested the wireless adapter device on Windows and it works just fine.

Check the wireless adapter is supported by Linux. Not all of them are. There's a list somewhere of the drivers in the raspberry pi kernel.

it says it’s supported but whatever ill just buy wi-pi

It's not on the elinux list that comes up on Google. The Berlin n300 is, but that appears to be a different chipset to your netgear n300. Hope you have more luck with a different dongle.

I see what I did… the elinux site lists: WMA3100M when mine is WNA3100M