Wlan not working, although router assigns ip address

my rpi (I think B+) with the 0.7rc4 versionl works well when connected to the router through ethernet, but when on wlan, although the router assigned it an ip (i can see it on the router’s web interface) and the musicbox tells me it can be reached on that ip in the startup log, I cannot connect to it in any way. Neither through http://musicbox.local, nor through IP, nor through (activated) SSH. Through the terminal I can’t even ping it.

Is the dongle the problem?

thank you very much

The dongle or the power supply would be my guess. What dongle is it?

Hi, thank you for the quick reply!
It is a Delock, model 88530 WLAN USB Adapter FCC CE 1177

It has been sent with the rpis (I got 5 and 5 adapters) and it had never been a problem to find them with router and ssh, til now. Same with the power supply (output 5V 2A)

Do you have a suggestion what dongle would work (I know these things can be quite unstable)?
Should I use a higher power supply?

I too am having difficulty with an ( approved ) Edimax dongle. I know the issue appears to point to a wlan0 issue. Until I can get this figured out I am at a stand still. I know so little about Pi, that i have been reading up on the issue for a few weeks with no success.
I am also using a 2.2 amp usb power supply and stand alone router with the intent to use the system as stand alone with the pi node 0 WD. Any tips are appreciated.

Are you seeing the exact same thing as described by the OP? Exactly what dongle is it? Approved by who? Are you sure this “stand alone router” setup is working? Can you connect other devices to it?

Hello, I am using a Edimax EW-7811Un which after researching is popular for Pi.
I have tried connecting to my home router and a NetgearWGR614 that I defaulted and set up to use as LAN only.
I have got as far as connecting to the network with my samsung phone to musicbox.local, but the circle just spins. at one point I was able to make changes with the settings file, but that appeared to be corrupt so I downloaded a fresh 0.7rc4 and just added the SSID and password to the configuration settings.

I think I have to spend time learning to set up wifi on the pi 1st; then come back to this project.
Bob D

Morning Bob,

I don’t think you can connect to musicbox.local using android on your phone, you need to specify the actual ip address, this is from the manual
"If it doesn’t work, or if you use Android (which does not support Bonjour/Avahi/Samba), you have
to access MusicBox using the IP­address of your Pi. This address is different on every network,
e.g. or You have to either look it up using a network utility, or
(easier) read it from the screen when Pi MusicBox boots."

Have you tried musicbox.local from a computer?

Step back.

Can you find the Pi’s ip address in your router’s clients list?

Does it ping?
By name?
By IP address?

If it pings: Can you use PuTTY (or equivalent) to SSH on to the machine? If it only pings via IP address, use the IP address from here on out.

Now you’re ready to test some more.

In my case, I haven’t gotten the Pi’s to ping by name. Everything I do needs to be done via IP address. This is not a Mopidy issue, it’s likely my router configuration or it may be the way I have Raspbian configured, since the machines were set up in very similar manners. Since it’s just me using it, control by just IP address doesn’t bother me that much.


(I will join this thread, since is a very similar question. Just let me know if I should start a new thread.)

I am having a similar problem as OP. However, in my case, I was able to connect to pimusicbox about ten times, using wireless and IP address from tfirefox running on a desktop PC. Then, one day, it just stopped working.

I can still ping to pimusicbox, by IP address. However, when I point the browser to it, nothing happens.




this is an Update of the configuration. I bought a Pi3, with integrated wlan and the official power supply.

I used Etcher to burn the image on a micro SD card. I could open it and configure the file where I can put the network configuration and put shairport on ‘true’.

I started the Pi. On my router I can see its IP But through terminal I can’t ping it and iTunes can’t find musicbox.

What’s up? Any tips? Router is a FRITZ!Box Fon WLAN 7170, Firmware-Version 29.04.12-4298

Thanks a lot raspipeople

Are you able to plug in a hdmi cable and see the error messages on the screen?

Hi, I finally plugged a monitor.
The loading text shows no error message, the last lines are:

My IP adress is
Connect to me in your browser at http://MusicBox.local or

Musicbox v0.7.0RC4
Musicbox login: [ 100.353182] random: crng init done

My router sees the device but does not give it a name
I can’t connect to it neither through my laptop (apple) nor through my android phone.

I upgraded to v0.0.7.0RC5 but the situation remains the same
Any tip?