MusicBox will not start if GPIO serial (UART) enabled

I have a Pi3B, running musicbox_v0.7.0RC6. Nothing else installed.
Pi3’s don’t have GPIO serial enabled by default, so I added

enable_uart=1 to /boot/config.txt

Now the Pi hangs at boot with:
Kernel panic - not syncing: Attempted to kill init! exitcode-0x0000000b

If I comment out enable_uart=1 from config.txt, MusicBox boots just fine.

Anybody have any insight into what I need to check to get MusicBox to boot when GPIO serial is enabled? Other pins appear to work fine, it’s just when I enable serial, as above.


Is it just me? Has anybody else been able to activate GPIO UART and have MusicBox boot properly?

Might seem a daft question but once up and running have you tried the GPIO?

I picked up a Pi3B today. Using the card from a Pi0 that was running Musicbox and lirc (utilising the GPIO) from here and having attached the IR receiver to the GPIO it worked straight away.
There was no need to enable the GPIO seperately.

Hmmmm. So I’m trying to connect power and activity LEDs* to my MusicBox Pi and following this instructable:

(using a Pi 3B, instead of a Zero, of course)

And I’m getting the behavior of the power LED (on pin 8) illuminating for 2-3 seconds on first boot up and then turning off (it is supposed to be constant on). In reading the comments on this page, and other Googling, it seemed like this was a result of the GPIO serial port not being activated by default on the Pi 3’s, and that I needed to add the UART parameter in the config.txt (step 3 of the guide)

You’re saying the Pi3 you just picked up GPIO is already activated?

*also looking to add a power button, but haven’t gotten there yet.

I think GPIO is ok but you need GPIO UART which is not mentioned in the first post
I am using pins 2,(5v) 6(gnd) and 12, you need pin 8 which is not enabled, that’s why mine started up ok.
Once the musicbox is running have you tried sshing in and using enable_uart=1 to see if that works?
I have tried putting enable_uart=1 at the bottom of /opt/musicbox/ and it booted up ok, however I don’t know if the pin is working as I don’t have anything to check it with.
I don’t know if putting the instruction in this is recommended or indeed will work, so try it at your own risk.

I’ve been operating under the assumption that “enable_uart=1” is a config parameter, rather than an instruction (ie - it’s read when needed, but not really executed in the common sense). Is this not true?

Either way, I have now tried SSH’ing in and executing enable_uart=1, as well as adding it to the end of (separate sessions)… no joy on either.

I’m wondering if another pin might be more suitable. I don’t necessarily need constant on for the indicator… it’s okay if it flashes with activity… I just need to differentiate if the Pi is actually running vs. halted (with the power still on).

Barring that, still unable to get serial/UART activated. :frowning:

I don’t know.

When I first read this topic I was interested as I use Musicbox with IR receiver to control it. GPIO & IR have worked fine on each different Pi I’ve used it on and I couldn’t understand why you had a problem with it on the latest model, however the initial title was a bit misleading as it’s only the 1 pin that doesn’t work, the rest appear to behave as before, this should mean you will be fine to set up button controls for Musicbox but doesn’t solve your LED problem.
I’ve spent a couple of hours trying to figure it out but I’m afraid I’ve been unable to.

Sorry about that, Steve.
I can see, now, how the title is misleading. It SHOULD be “MusicBox will not start if GPIO serial enabled”. Though my OP does mention the UART parameter, so that’s a bit of a clue.

When I posted, I hadn’t tested other pins because the TXT was the only one that would do what I initially needed to do.

But I’ve since written a script that I spin off on a separate thread before MusicBox loads, that lights the LED using a different GPIO pin. Hopefully it doesn’t eat up resources and make MB run slower, but for now it’s working.

Sure would like to understand why serial doesn’t work, though.

(UPDATE: I’ve revised the post title, and my OP to make things more clear)

I had the very same issue yesterday. I wanted to do the same and couldn’t boot because of the kernel panic

Did you have any luck with it yet? I wanna do a Power LED as well so the users know when they can cut off power.