Pi MusicBox won't boot on R-Pi Zero W


#1

Hi,

Today I received my brand new R-Pi Zero W that I planned to use as a Chromecast Audio, meaning with Pi MusicBox and connected to my SPL Crimson audio interface via USB. Therefore, let me point out that this is the first raspberry machine that I ever use in my life (so you can expect some noob questions from time to time), still I have some knowledge in Linux systems and programming (C/Python/HTML/CSS/JS/PHP).
So, I formated my 4Gb class 4 microSD and installed Pi MusicBox with Etcher on it.

But I’m running into an issue when I boot my Pi Zero: The green LED is blinking 8 times (loop) which means (according to what I read on the internet) SDRAM not recognised. You need newer bootcode.bin/start.elf firmware.

I used the 0.7.0RC5 (following the build instructions on the github page) and the resulting image’s size is 922 534 400 bytes (approx. 922.5 MB). Does-it sound ok to you ? (I can provide an MD5 hash if needed)

Also, I’ve never booted successfully my pi zero as it is new, could it be this causing the problem ? Do I need to boot to Raspbian or something, update some internal firmware and it’ll work fine after this ?

Thanks for your help


#2

You should not need to boot into Raspbian first, I’ve never heard of this (although I’ve always happened to have done it). I’d be surprised if the bootcode version on v0.7RC5 is not new enough to support the the latest hardware but maybe you could try the latest version of Raspbian as an experiment?


#3

So i tried to boot the latest Raspbian, everything went smoothly as I could access the TTY (still, I couldn’t do an apt upgrade as I currently don’t have an external keyboard).
Thereafter, I tried to boot Pi Musicbox 0.7RC5 but ran into the same issue as the first time: no video output, only the green led blinking 8 times. Also tried with the v0.6, same issue as with the 0.7RC5…

Any idea of what’s preventing my RP Zero W to boot Pi Musicbox ?


#4

Are you using the same SD 4gb card for Rasbian as you did for PiMusicbox?


#5

Indeed I was :slight_smile: useless text to reach the 20chars/post minimum


#6

I will upload an updated image for you either tonight or tomorrow.


#7

Wow, that’s very nice of you ! Thanks alot, can’t wait to try your work :smiley:


#8

I have uploaded an image at https://drive.google.com/open?id=0ByrmzcQJL5t1UHJ5TTItbmhKeVU

I have updated the Linux kernel and the firmware to the very latest versions. However, I have not even tested this myself yet, I won’t get a chance to until tomorrow evening some time.


#9

First, thank you for you reactivity ! This version is booting fine on my RP Zero W. Unfortunately something strange is preventing me to use the webclient:

For a start, it is displaying this error Pass 5: Checking group sumarry information failed (code 1), then it connects to my WiFi without any issue, launches the server. I can then see the MusicBox device showing up in the connected devices on my WiFi AP but when I try to access its web interface, the loading fails and displays a ERR_CONNECTION_TIMED_OUT and the RPi Zero W disconnects from the WiFi AP (never reconnecting afterwards). I also have this error if I try to connect to the SSH while it’s still connected to the AP: ssh: connect to host 192.168.1.36 port 22: Resource temporarily unavailable.

edit: screen output is also flickering alot


#10

I will dig out my RP Zero W but since my one works with the old firmware I am not sure I’ll be able to reproduce some of this. The screen flickering in particular sounds odd.

That “Pass 5” error is from the filesystem check which normally indicates a problem with the SD card.

Are you using the IP address or the hostname/zeroconf in your web browser?


#11

I’ll try to find another SD card to try with in few days

I tried with http://MusicBox.local and also with the local IP (which was 192.168.1.36 at that time) in the browser, none worked.

Screen flickering seems to happen more in the beginning of the boot process than after the server’s launched, still it is looks pretty random.