Mopidy Discourse

Pi 3b+ / v0.7.0 musicbox wont boot

Hello i am new to PI and Musicbox, i followed the quickstarts and i cannot get my pi to boot.

  1. connected a monitor and found it hung at
    “random: crng init done”

    • google search suggested i connect keyboard and press enter. No help
  2. Google search also suggested i change cmdline.txt root path. was root=/dev/mmcblk0p2.
    changed to root=/dev/sda2

    • This sortof helped. From here it boots to a error: File system check failed …
    • i can either enter a password (musicbox) to get to a manual repair console. or i can press Control+D to continue boot. The password gets me to a root console, but i dont know what to do there.
      ctrl+d gets me a couple more errors, but it ends up with the musicbox splash and the IP address. However, i cannot connect with a web browser. I can PING it, and it replies.

the error i see getting into MB is “Mounting local filesystems…mount: Special device /dev/mmcblk0p1 does not exist”

thanks!

update.
I ordered a new SDcard, just incase its broken. Same results.
Any support would be great

Hi Kevin - just came across your post and thought I’d comment. I finished installing v0.7.0 on my RPi 3B+ a minute ago, and it worked right away without any modifications. cmdline.txt contains root=/dev/mmcblk0p2.

I realise this isn’t a suggestion as in “try this or that” but maybe it helps insofar as this suggests either your HW is faulty, or you haven’t installed it correctly.

I followed the instructions in Raspberry Pi als Jukebox für Google Music, Spotify oder Musik vom NAS | Linux und Ich (German, so stick it into Google Translate if you don’t understand it).

Good luck, Uli

Just reading again the details of the problems you’re describing, I would try to write the image to the SD card using a different method from the one you’re currently using. There are many methods/tools that do this, have a look at some RPi “how to’s”.

The reason why I’m suggesting this is that mmcblk0p1 is the boot partition (which will by mounted on /boot in the running system), so if your RPi complains about this not existing, something is wrong with the SD card.

In my experience not all these tools for Windows to write images are created equal. I always use Linux (dd) for this because Windows (and some Windows security software) tries to second-guess your actions at that “bare metal” level and sometimes interferes with what you are trying to achieve. “dd” just dumps the image, no safeguards.

Hello Uli,
thanks for your reply… i guess there is a problem with the hardware somewhere. I tried to write the image with Win Disk Imager, and also with Etcher SD.

its very strange behavior. maybe my PI is DOA.

kevin

Hm. Three more checks:

(1) Have you verified the checksum of the downloaded image?

(2) Have you tried to disconnect everything from the Pi except a LAN cable, then ssh into it (find the assigned DHCP address in your router)? This solves the situation where the boot hangs on some attached HW issue, including resulting power issues.

(3) Finally, if you don’t have a running Linux PC/laptop anywhere, create a USB stick with a live Linux, boot from that, then attach the SD card for the RPi in an SD card reader, check the integrity of the two partitions (fsck), and if that checks out, mount the partitions and inspect them (folders/files).

If all that goes well, then I’d wager your Pi is broken. I have this MusicBox RPi running 24/7 since the install and it’s rock solid. Quite amazing. Hope the developer will maintain it (the used OS is getting a bit long in the tooth, and I see failed attempts by others to update it).

Before you write the pi off, have you tried installing Buster or any other os on the card. If that works then try installing Mopidy - it’s quite simple to install and long term will probably give better results than musicbox. There will be plenty of people will help you with any installation queries you have.